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How to use this guide

How to use this guide
This manual should be used as a point of reference following attendance of the introductory level FrontPage 2002 training 
course. It covers all the topics taught and aims to act as a support aid for any tasks carried out by the user after the course.

The manual is divided into sections, each section covering an aspect of the introductory course. The table of contents 
lists the page numbers of each section. 

All graphics related to Microsoft in this book is in compliance with Microsoft guidelines and thus permitted by Microsoft.

Objectives

Sections begin with a list of objectives each with its own check box so that you can mark off those topics that you are 
familiar with following the training.

Instructions

Those who have already used FrontPage before may not need to read explanations on what each command does, but 
would rather skip straight to the instructions to find out how to do it. Look out for the hand icon which precedes 
a list of instructions. 

Keyboard

Keys are referred to throughout the manual in the following way:

[ENTER] – denotes the return or enter key, [DELETE] – denotes the Delete key and so on.

Where a command requires two keys to be pressed, the manual displays this as follows:

[CTRL][P] – this means press the letter “p” while holding down the Control key.

Commands

When a command is referred to in the manual, the following distinctions have been made:

When menu commands are referred to, the manual will refer you to the menu bar – E.g. “Choose File from the menu 
bar and then Print”.

When dialog box options are referred to, the following style has been used for the text – “In the Page Range section 
of the Print dialog, click the Current Page option”

Dialog box buttons are shaded and boxed – “Click OK to close the Print dialog and launch the print.”
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Notes

Within each section, any items that need further explanation or extra attention devoted to them are denoted by shading. 
For example:

Note: This creates a new page based on the same style of an open page in the Editor. It can look like nothing has 
happened therefore. A new page is created and named newpage1.htm.

Tips

At the end of each section there is a page for you to make notes on and a “Useful Information” heading where you will 
find tips and tricks relating to the topics described within the section.
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Essential Web Concepts

1	 Essential Web Concepts
By the end of this section you will be able to:

•	 Understand common terminology associated with the Internet, Intranet and World Wide Web 
•	 Understand URL’s
•	 Organise your Web’s Structure
•	 Understand good Web design
•	 Mapping out your web
•	 Webs 
•	 Pages
•	 Hyperlinks

http://bookboon.com/
http://bookboon.com/count/advert/7df08111-c180-4bd8-97db-a2d500e6043a


Download free eBooks at bookboon.com

Frontpage 2003

12 

Essential Web Concepts

1.1	 Common terminology associated with the Internet, Intranet and World Wide 
Web

Webs

At all times in this manual, whenever webs are referred to, the analogy of a web - in terms of connectivity, is being used. 
Just as a spider’s web is interconnected at lots of different points, the Internet is connected by telephone lines and servers. 
A web ‘site’ is a collection of web ‘pages’ all connected together by links.

The Internet

The Internet is a collection of computer networks that connects thousands of computers around the world including the 
one on your desktop. It is also a vast source of information that is constantly changing and expanding. Since it’s creation 
in the 1960s it has grown exponentially and is now used by millions of people, from those in commercial and educational 
institutions to individual consumers.

The World Wide Web’s Place on the Internet

The World Wide Web is one facet of the Internet consisting of client and server computers handling multimedia documents. 

Web documents can make full use of multimedia features such as text, images sounds, movies or a combination of all 
of them.

Although the Internet consists of several other facets or services, such as e-mail, Gopher, and File Transfer Protocol or 
FTP, the World Wide Web is the fastest growing and most used service. The Web is a series of interconnected groups of 
information that allows you to see full-colour graphics, hear sounds and music, chat with other users, download files, 
and access more information in minutes than you could previously access in months.

Information is exchanged on the World Wide Web using servers and clients. The server is the host computer, which stores 
documents and makes them available on the Web. The client is the computer that requests this information. Clients use 
web browser software to view and retrieve information from the host computer, or web site.

Clients and servers communicate with each other on the World Wide Web using Hypertext Transfer Protocol (HTTP.) Using 
this protocol, documents in the form of text, graphics, audio, and video can be transferred between computers. HTTP is 
layered on top of TCP/IP (Transmission Control Protocol/Internet Protocol.) TCP/IP enables different types of operating 
systems, such as Windows, Macintosh, UNIX, and more to communicate smoothly with one another. 

A key ingredient of documents on web servers is hyperlinks. Hyperlinks join together documents on the Web. These 
documents can be on the same web server or on another web server anywhere in the world. Your browser software displays 
these links as graphics, buttons, or underlined text. To jump to a link, you simply click it with your mouse.

http://bookboon.com/
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Web Pages

A home page is the first screen, or page, that you see when accessing a web site with a browser. Additional documents at 
the same site are known as web pages; you can reach them through the home page or via other links. A home page and 
the pages, files, graphics, and other media associated with it are called a web.

Each web page has a Uniform Resource Locator (URL), which is an address computers use to go to a desired location in 
the Web. The URL consists of the protocol, the server and, if necessary, the path name of the document. The format is 
always the protocol followed by a colon, the server name preceded by two slashes, and each segment of the path name 
preceded by one slash. For example, look at the URL for the National Space Science Data Centre, shown below

Internet Vs Intranet 

An Intranet is...

With the growth of the Internet, many companies began to realise what a valuable information tool the World Wide Web 
(WWW) could be. Some companies began to create Intranets, or internal web sites listing information relevant to all 
employees. Because Intranets are easily accessible from each workstation, companies found they could not only reduce 
paper costs, but also reduce frustrating phone tag and information lag time.

Intranets can contain marketing and product information, company newsletters, human resources information, job listings, 
office supply inventory, and important company databases. Companies can even create forms on an Intranet so employees 
can make requests for information, sell unwanted items, download software and so on.

Intranets are also a good place to discuss business issues and solve problems. The scientific and medical communities have 
benefited from the speed at which information is shared on an Intranet. Instead of spending hours or days researching a 
problem, researchers can often find a solution in minutes over an Intranet.

1.2	 Jargon and Terminology…

Here is a brief list of the more common jargon; a fuller explanation may be given throughout the manual as topics are 
covered.

Frame

A frame within a page is in essence, a smaller page within a patchwork page. Each frame has a characteristic of a page. 
Clicking on a link within a frame can bring new information within the frame or to a different frame. Likewise a link can 
bring an entirely new top-level page replacing all the frames. 
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URL

Uniform Resource Locator is a document’s unique address location e.g.: http://home.netscape.com

Web browser 

A software application used to view documents by client computers such as Netscape Navigator and Microsoft Internet 
Explorer.

Links or HYPERLINKS

A link is a connection from one page to another usually denoted by a word in a different colour or underlined.

HTTP

Hypertext Transfer Protocol is a manner for interpreting computer information. HTTP is the most common protocol 
for Internet Pages.

HTML

Hyper Text Mark-up Language is the code that Web document authors use to create graphical links to other documents.
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Mail Message

An individual sends a mail message to an e-mail address for collection.

1.3	 Why FrontPage?

Traditionally, web pages were designed with HTML code and many web designers still write entire web pages in HTML 
using such basic applications as, would you believe, Notepad. Next came Graphical User Interface (GUI) applications 
that allowed web page design with no knowledge of HTML. Microsoft Publisher and Microsoft Word for example, both 
allow creation and editing of web pages in a GUI environment. No need to know code!

FrontPage not only allows you to create and design web pages as you will see them when they’re finished (in a GUI 
environment) but shows you your web as a tangible object. That is to say, you can see all the pages in the web on the screen. 
In reality, only people who have had to create pages in HTML or even those who have had to use Word to create pages 
will really appreciate the full glory of FrontPage. With FrontPage certain tasks become things of the past: losing pages; 
constantly fixing or manually recalculating hyperlinks; switching back and forth every few seconds to a browser to check 
the state of the pages; losing track of who in your team has completed which section of as web project. And much more! 

Above is a view of HTML code, written in Notepad and below is the FrontPage Editor. 

Both are design tools for web pages.

http://bookboon.com/
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Organising Your Web’s Structures

It is essential with web page design to get a grasp of exactly what you want from the web. This means writing down a list 
of aspects and desired components. A diagram would help too, showing an actual web of pages or tiers.

http://bookboon.com/
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Understanding Good Web Design

The web must have a home page. This means a page at the top of any tiered structure or at the centre of a web you design 
on paper. 

You should name the home page Index.htm (or Index.html) in line with web server protocol.

All the pages can be linked so don’t worry about cramming too much on one page. It’s better to use lots of pages with a 
small amount of information on each.

Think about any links you might need to other sites or sites on the World Wide Web. Add them into your diagram.

Try to think up page (file) names with eight characters or less. Although many servers and systems now support long 
filenames, it isn’t universal by any means. It may save you some time and effort in the future.

Agree on a contact name for one person (sometimes called the webmaster) who will be the first contact for web 
browsers visiting your web. Make sure this person has an E-mail address or maybe create an address - webmaster@… or 
administrator@… especially for your web. These are familiar terms to web browsers.

The value of designing your web on paper cannot be emphasised enough. It is invaluable to have a very clear idea of what 
it is you want in terms of your web. So think about what you want your web site to do and what sort of information it 
should provide. Think about who will be browsing it and how you would like information presented.
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Many of your thoughts can be presented roughly, even at this early stage, on paper. Something like the example below.

This structure is generated by the suppositions that:

•	 You need a Home Page - or the first page browsers will hit.
•	 You want to categorise your recurring events.
•	 You want to link these pages in some way.
•	 You want links to the actual World Wide Web site of the events you handle.

You see that it’s already taking a web structure?
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2	 FrontPage Views
By the end of this section you will be able to:

•	 The Page View
•	 The Folders View
•	 The Reports View
•	 The Navigation View
•	 The Hyperlinks View
•	 The Tasks View

 

  

 

                . 
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2.1	 FrontPage Views 

FrontPage provides six views, each of which allows you to look at and work on a web in a different way.

•	 The Page View
•	 The Folders View
•	 The Reports View
•	 The Navigation View
•	 The Hyperlinks View
•	 The Tasks View

(If the View bar is not visible, you can show it by choosing View, Views Bar.) 

Elements of the View Bar

The Page View

This allows you to create, edit, and view your web pages. Page Tabs make editing many pages at once easier. You can 
open several pages in FrontPage; you can switch from page to page with just a click on the tab that represents that page.

http://bookboon.com/
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There are separate views within Page View

•	 The Normal View – The “word processing” style interface
•	 The HTML View – This view give you direct access to the HTML code that FrontPage generates. You can 

view directly or edit the HTML code in this view. HTML attributes and their values are colour coded so that 
you can distinguish them more easily

•	 The Preview – This view allows you to quickly preview the current web page, giving you an idea of how it 
will look and function in your browser

You can quickly preview the way your page will appear in your browser by clicking the Preview button at the button of 
the Page view window. This will display the page within the preview pane, which will render the page almost as if it were 
opened in your browser. To resume editing the page, click the Normal button to reopen the Normal pane.

2.2	 Opening a Web in Page View

If you already have FrontPage open, you can use the Open FrontPage Web button on the toolbar, or the Open FrontPage 
Web command from the File menu.

Webs are associated with individual server addresses. When you access a server address, you list all of the webs associated 
with that address. From the Open FrontPage Web dialog box, select which web to view or edit by listing the webs associated 
with a server, and then make your selection.

To open a web
•	 From the File Menu, choose Open Web.

http://bookboon.com/
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•	 Select the appropriate drive and folder where web is saved
•	 Select the appropriate web.
•	 Choose Open
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Closing a Web in Page View

When you are finished working with a web, it is important to close it properly. You can have only one web open at a time.

To close a web:
•	 From the File menu, choose Close Web.

Closing FrontPage

To Close FrontPage:
•	 From the File menu, choose Exit.

The Folders View

This shows a directory level representation of your web site and a properties list for each folder. It shows you all the web 
folders and the files contained therein. This view allows you to work with the folders and files, in a similar fashion to 
methods used in Windows Explorer.

The Reports View

This displays a variety of reports, which show the status of the file, Web pages, hyperlinks, enables you run reports for 
information such as the number and type of images on your page, broken or outdated hyperlinks, or pages that might 
be slow to load.
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The Navigation View

From this view you can create and manage the navigational structure of the web. You can also print a map of your web 
from this view

In the right hand pane, each icon represents a page within your web; a plus sign at the bottom of a page icon indicates 
that there is another level of hidden detail. To see the next level, click on the plus sigh. Note that a page does not have to 
be visible in the right hand pane to be a part of the web.

To hide the displayed level, click on the minus sign at the bottom of the page icon. This can enable you to view only 
certain sections of your web as you are working.
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By clicking on the folder list button, you can open or close the Folder

The Hyperlinks View

This graphical displays information on all hyperlinks in your Web pages and lets you check the integrity of those hyperlinks 
view presents a visual “map” of the hyperlinks to and from any page in your web site

The Tasks View

The Tasks View contains a list of “things to do”. General or unlinked tasks can be added in the Tasks View. 
A task specific to a particular page is created while that page is open in Page View
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3	 FrontPage Webs
After completing this section you will be able to:

•	 Create a one page web using FrontPage
•	 Choosing a location and naming a web
•	 Viewing a one page web
•	 Creating New web pages
•	 Saving new pages and renaming new pages
•	 Importing Pages
•	 Using the Folder List
•	 Working with Folders
•	 Moving pages to folders
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3.1	 Create a New one Page Web

Starting a One-Page Web from Scratch

Microsoft FrontPage has a host of templates and wizards and it is relatively quick and easy to create a multi-page web with 
these straight away. However, at this stage it is advisable to start with one page and learn the main editing and building 
techniques. Templates and wizards will be covered briefly at the end of this section.

Creating the Index (or Home) page

To create a one-page web
•	 Select File, New, Page or Web.

•	 In the New Page or Web task pane, under New, click Blank Page 

Naming and Saving a Page

Saving your work is important. It prevents you from losing work in case of a computer crash or power failure. 

In FrontPage, as in many other Windows applications, you can have several pages open at once, and you can easily switch 
between them using the Page Tabs or the Window menu. However, having too many pages open at once can be confusing, 
so it’s a good idea to close pages when you finish working with them.

To save a page:
•	 On the Standard toolbar, click the Save button.

Or
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•	 From the File menu, choose Save.

FrontPage will prompt you with the Save As dialogue box seen below allowing you to specify a folder location 
and a file/page name

http://bookboon.com/
http://bookboon.com/count/advert/09268424-498c-48c4-a852-a25700ed3ed3


Download free eBooks at bookboon.com

Frontpage 2003

31 

FrontPage Webs


To close a page:

•	 Click the document Close button.

Or

•	 From the File menu, choose Close.

Viewing a One-Page Web

It will be useful for you now to look at your simple web in the different views to get to know them a bit better.

FrontPage has made your page the Home (or Index) page and this starts as the centre of your web or the top of a tiered 
structure

You currently have one page in your Web. 

To change views, in the View bar on the left-hand side, click the Folders View icon. This view will display all the folders 
and pages created within your web. By default, you will have the images and _private folders set-up. For example, the 
Images folder will contain all the images and pictures you use within your web.

Click the Hyperlinks View icon. There are no hyperlinks but it gives you the idea of the first, central, page in your web. 
Conversely, click back to Page View to see your home page.

3.2	 Creating new pages

Web pages can be added to the web in either Page View/Folder View or Navigation View. Ideally, pages should be added 
in the Folders View to help you keep track of file and folder management in the web. However, only blank pages can be 
added this way. If you want to add pages based on templates or wizards, you have to add them in Page View.

To Add a Page in Folder View
•	 Make sure you have a web open and are in the Folders view.

•	 Click the New Page button 

•	 A new page appears in the right hand pane.

Note: If you do not have an Index or Default page in the folder that is open when you add a new page, FrontPage will 
name the new page Index.htm. Otherwise it will call it newpage1.htm (…newpage2.htm etc.)

To Add a Page in the Page View
•	 Make sure you have a web open in Page View
•	 Click the New Page button on the toolbar.

Note: This creates a new page based on the same style of an open page in the Editor. It can look like nothing has 
happened therefore. A new page is created and named newpage1.htm.
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Or

•	 Select File, New Page or web from the menus.
•	 In the New Page or Web task pane, under New from Template, click Page Templates…..  This opens the 

New Page dialog box, shown below

•	 Click the tab for the template you want to use, (a thumbnail of that template is displayed under Preview). 
•	 Click OK. 
•	 Microsoft FrontPage opens a new page based on the template

3.3	 Saving New pages and renaming Pages

To save a page created in Folder View
•	 New web pages created in Folder View are automatically saved as new_page_1.htm, new_page_2.htm etc.

To rename a page created in Folder View
•	 In Folders view, right-click the page/file you want to rename, and then click Rename on the shortcut menu. 
•	 Type a new name for the page/file 

mk:@MSITStore:C:\Program Files\Office2K\Office10\1033\fpmain10.chm::/html/fpCreateNewWebPage.htm##
mk:@MSITStore:C:\Program Files\Office2K\Office10\1033\fpmain10.chm::/html/fpCreateNewWebPage.htm##
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Note: When renaming a file, be careful not to change or omit the file extension (for example, make sure you don’t change 
the file name from Index.asp to Index.htm). Changing or omitting the extension of a file might render the file unusable. 

Note: Microsoft FrontPage automatically repairs any hyperlinks to or from the renamed file (or files in the renamed 
folder). If you rename a file or folder using Microsoft Windows Explorer, hyperlinks to and from that file (or files in 
that folder) will not be repaired automatically. 

To save a page created in page view
•	 When you close the new page, you will be prompted to save the page and specify the location to which you 

wish to save it.

To save the page prior to closing
•	 Choose File Save 
•	 Specify the directory location you wish to save the page into and specify the file name you wish to give the 

page
•	 Choose OK

3.4	 Importing Pages

In addition to creating web files and folders within FrontPage, you can also import them from local or network disks 
or from the Internet. Importing files is especially important if you’ve been using another program to create Web pages, 
graphics files, and other web files and you now want to make those files part of a FrontPage web.
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To import one or more files or folders 
•	 In the Folder List, select the folder in which you want to store the file(s) or folder(s) you’re importing.
•	 Choose File, Import to open the Import dialog box shown below. You can choose this command when any 

view is active except the Reports and Tasks views

•	 In the Import dialog box, do one of the following:
•	 To import one or more files or folders (plus all files in the folder) from local or network disk locations, 

add each of them to list. To add a file, click the Add File button; to add a folder (together with all the files 
contained within), click the Add Folder button. When all files or folders you want to import are displayed in 
the list, click the Ok button

•	 To import a folder together with all of the web pages or other web files it contains, either from a disk 
location or from the Web, click the From Web button to run the Import Web Wizard.

•	 With either technique, FrontPage will make a copy of the imported folders or files, leaving the originals 
intact.

Note: Be sure to use one of the importing methods discussed here rather than using Windows Explorer to copy files in 
to one of your web’s folders so that FrontPage is properly apprised of the files you’re adding to the web

Importing non-html files

By using the Import command you can actually import any type of file, for example a Word document. Be aware, however, 
that the import function does not make any conversion to html. 
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You can still create hyperlinks to this “non-html” file. When a visitor follows a hyperlink to this file, the Web browser will 
launch the required application, so that the user can view the file correctly.

Using non-html files within you web is a powerful way to share any general data. 

There are several important issues you need to be aware of:

•	 An application that understands the format of the file will be required so that the user can view the file 
correctly. 

•	 If the visitor does not have the necessary application they will not be able to view the file
•	 File size is usually much larger than HTML files and therefore increases download times. 

3.5	 Using the Folder List

Folders view is shown below. The left part displays a hierarchical list of all folders. You can expand and collapse a branch 
by clicking the box that has the plus (+) or minus (-) symbol. You can also select the next folder up in the hierarchy – if 
any – by right clicking a blank spot in the right pane and choosing Up One Level from the shortcut menu. Open a folder 
by clicking it in the Folder List, the right pane will then display the files and folders that are contained in that folder.

Note: You can display a Folder List in Page, Navigation, or Hyperlinks view. If the Folder isn’t visible in one of these 
views, you can display it by choosing View, Folder List. The Folder list displayed in Page, Navigation or Hyperlinks view, 
unlike the one shown in Folders view, displays the files contained within each folder as well as the folders themselves.
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3.6	 Working with folders

In Folders view, you can create, delete, rename, move or copy folders using the same basic methods as in Windows 
Explorer. The following is a summary of main functions in folder management.

What I would like to do How to do it

Create a new folder

•	 Select the folder you wish to create the new folder in. 
•	 Right click a blank area in either the Folder List or in the right 

pane of Folders view and choose New, Folder

Delete a folder
•	 Right mouse click on the folder, and choose Delete
•	 Say Yes to the Confirm Delete?

Rename a folder •	 Right mouse click on the folder and choose Rename

Move (or copy) a folder
•	 Use the mouse to drag and drop the folder to a new location (To 

copy the folder, press Ctrl while you drag

3.7	 Working with Web files

You can also use Windows Explorer methods in Folders view to select, delete, rename, move, copy, or open web files. The 
following table summaries the main functions for working with Web Files 
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To do this with Web Files Perform This Action

Select all files in currently opened folder

•	 Choose Edit, Select All
•	 Press Ctrl + A 

(Only available in folders view)

Delete a file

•	 Right-click the file and choose Delete 
from the shortcut menu.

•	 Select the file and press Delete

Rename a file

•	 Right-click the file and choose Rename 
from the shortcut menu.

•	 Select the file and press F2

Move (or copy a file)

•	 Select the file, choose Edit, Cut (or 
Copy) and then select the target folder 
and choose Edit, Paste

•	 Use the Cut (or Copy) and Paste 
commands on the right-click shortcut 
menu in the same way

•	 Use the Cut (or Copy) and Paste toolbar 
buttons in the same way

•	 Use Ctrl + X (Cut) or Ctrl + C (Copy) 
and the Ctrl + V (Paste) shortcut keys 

•	 Use the mouse to drag the file to the 
new location. (To copy the file, press Ctrl 
while you drag.)

Open a file

•	 Double-click the file
•	 Right click the file and choose Open 

from the shortcut menu.
•	 Select the file and press Enter
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4	 Adding Text
By the end of this section you will be able to:

•	 Enter, Edit and delete text 
•	 Move and copy text
•	 Use line breaks
•	 Insert Dates and Times
•	 Insert special text characters
•	 Use the spell checker and Thesaurus
•	 Find and Replace text
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4.1	 Common Editing Tasks

Enter, edit, and navigate through text in Page view using the same basic methods as in Microsoft Word. As in Word, you 
should let the text wrap automatically as you type a paragraph and press Enter only to create a new paragraph. 

Note: The position where each line in a paragraph wraps will ultimately be determined by the width of the browser 
window used to view the page.

Selecting

You can select blocks of text – including any embedded images, horizontal dividing lines, or other elements – by holding 
down the Shift key while you press the down arrow key or by dragging over the area with the mouse.

You can also use almost any of the Microsoft Word selection methods.

You can select individual non-text elements, such as images, horizontal dividing lines or Web components by clicking 
on them.

To select all text and elements in the main page
•	 Choose Edit, Select All
•	 Or choose 
•	 Ctrl + A

To Delete Text
•	 Select text as outlined above and press Delete

4.2	 Move and Copy Text

You can move or copy blocks of text or other elements (such as images, horizontal lines, and web components) by using 
the same basic methods employed in Word.

You can move the selected item by dragging it with the mouse or copy it by pressing Ctrl while you drag. You can also 
use the Clipboard to move or copy it by means of the standard Cut, Copy and Paste commands. You can move or copy 
within a single page, between separate pages, or between documents. 

Paste Options

When you paste text into a page, FrontPage chooses a default formatting option, but displays the Paste Options button 
so that you can select a different option. The available formatting options depend on the source and formatting of the 
text. For example, if you paste several paragraphs copied from a Word document, the Paste Options button gives you the 
choices shown below:
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You can switch between choices to see which creates the effect you want.

Note: FrontPage displays the Paste Options button only if the Show Paste Options Button option is checked. You’ll find 
this option by choosing Tools, Page Options and looking in the General Tab

You can select from a greater number of formatting options by using the Paste Special dialog box, rather than the standard 
Paste command and the Paste Options button. 

To control how the text if paste in to your web page
•	 Choose Edit, Paste Special to open the Convert Text dialog box, shown below

Then, select one of the following options:

•	 To insert the text as a single paragraph assign the Formatted style, converting each paragraph break in 
the original text to a line break(and preserving all line breaks in the original text), select One formatted 
paragraph

•	 To assign the inserted text the Formatted paragraph style, preserving the paragraph breaks in the original 
text (and converting line breaks to paragraph breaks), select Formatted Paragraphs

•	 To apply the current formatting at the position in the page where you insert the text, preserving the 
paragraph breaks in the original text (and converting line breaks to paragraph breaks), select Normal 
Paragraphs or Normal Paragraphs With Line Breaks.
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•	 To render any HTML elements in the pasted text (rather than displaying the tags as literal text), removing 
all paragraph and line breaks, select Treat as HTML. For example, if the text contained <b>Madonna</b>, 
FrontPage would display the word important in bold and wouldn’t display the <b> and </b> tags

4.3	 Using Line Breaks

You can insert a line break within a paragraph. Most browsers insert extra vertical space between separate paragraphs, but 
not between lines separated by line breaks, so you can use a line break rather than a paragraph break so space separate 
lines more closely

Add a new line of text within a paragraph
•	 In Page view, position the insertion point where you want to insert a line break. 
•	 On the Insert menu, click Break. 
•	 Click Normal line break. 

Or

•	 Press Shift + Enter

Note: To view line breaks and paragraphs marks click Show All button  on your standard toolbar
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4.4	 Add a time stamp to a web page

A time stamp will display either the time or the date, or both, that the page was created or last changed. For example, a 
time stamp lets site visitors know whether the information on your site has changed since their last visit. 

•	 In Page view, position the insertion point where you want to place a time stamp. 
•	 On the Insert menu, click Date and Time. 

•	 Choose one of the display options
•	 Specify the type of time stamp to display. 
•	 Specify a format for the date and for the time. 

4.5	 Inserting special text characters

You can insert one of a selection of symbol characters not found on the keyboard.

To insert a special character
•	 Choose Insert, Symbol.
•	 Select the symbol you want from the Symbol dialog box (shown below)
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•	 Click the Insert Button

To insert the contents of an entire file 
•	 Choose Insert, File
•	 Specify the Files of type, the file location and the File name from the dialog box (shown below)

•	 Choose Open

Note: The Files of Type list box displays the different file types you can insert, which include HTML files, Rich Text 
Format (RTF) files, text files, Word documents, and Microsoft Excel workbooks. When you insert the file, FrontPage 
converts it to HTML form which makes it an integral part of your page
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4.6	 Spell Checking across the Entire Web

One of the tools FrontPage 2002 provides is an across the web spell checker. This lets you check each page in your web 
at one time, instead of having to go into each document making up the web. You start the Check Spelling dialog box, 
shown below, by selecting Tools, Spelling from the menu bar. At this point you can open problematic pages separately to 
view the possible spelling errors. FrontPage then takes you through what it thinks are errors in the same way as Microsoft 
Word and most other applications. In other words, you can Replace, Add to dictionary, Ignore and so on.
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To correct misspelled words in a web site, you can either add a task for each page in which Microsoft FrontPage 
finds misspelled words and correct them later, or you can correct the spelling immediately.

To check spelling across a web:
•	 Switch to Folders view by clicking on the Folder Icon from the View Bar 
•	 If you do not want to check spelling in each page in the web site, select only the pages you want 
•	 To select multiple, non-sequential pages, click the name of the first page you want to select, and then hold 

down CTRL while clicking the name of all the other pages you want to select.

•	 Choose Tools, Spelling. 
•	 Do one of the following: 
•	 To check spelling in all pages in the current web site, click Entire web. 
•	 To check spelling in pages you have selected, click Selected pages. 
•	 If you want FrontPage to add a task for each page with misspelled words, select the Add a task for each 

page with misspellings box. 
•	 Click Start. 
•	 When FrontPage lists the pages with misspelled words, do one of the following
•	 Correct misspellings in the task view later
•	 If you choose to create tasks for pages with misspelled words, the tasks are added to the task list. To correct 

the misspellings later, click Cancel.
•	 When you are ready to correct misspellings, switch to Tasks view, double-click a task labelled Fix misspelled 

words, and then click Start Task. 
•	 FrontPage opens the page in Page view and prompts you to correct the misspelled words. 

Find and Replace Text across the Entire Web

In a similar way to the Spell Checker, you can perform another word processor type task across the entire web. You can 
find and replace text from the explorer without having to run a Find on page after page.

To Start Find (and Replace)
•	 Switch to Folder view by clicking on the Folder Icon from the View Bar 
•	 If you do not want to search each page in the web site, select the pages you want to search. 
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•	 To select multiple, non-sequential pages, click the name of the first page you want to select, and then hold 
down CTRL while clicking the name of all the other pages you want to select.

•	 On the Edit menu, click Replace. 

•	 Do one of the following: 
•	 To search for text in all pages in the current web site, click All pages. 
•	 To search for text in pages you have selected, click Selected pages. 
•	 In the Find what box, type the text you want to search for. 
•	 To find text only if it matches a whole word, select the Match whole word only check box. 
•	 To find text only if it matches the capitalisation of the text you typed, select the Match case check box. 
•	 To find text in the HTML code, select the Find in HTML check box. 
•	 For example, you can search for text that is not visible or editable in the page, such as the page title you set 

in page properties. 
•	 In the Replace with box, type the replacement text. 
•	 Click Find in Web. 
•	 When Microsoft FrontPage lists the pages in which the text was found, do one of the following: 
•	 To open a page in Page view, double-click the page in the list. The first instance of the text is highlighted. 
•	 You can click Replace to replace this occurrence, click Find Next to find the next occurrence, or click 

Replace All to replace all occurrences in the current page. 
•	 When you have reviewed all occurrences of the text in the page, you are prompted to close the current 

document before continuing to the next one.

 Note that if changes were made, your page is automatically saved. 
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5	 FormattingText
By the end of this section you will be able to:

•	 Format text
•	 Change character spacing and positions
•	 Preview your web in FrontPage
•	 Preview your web in a browser
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5.1	 Formatting Text

You can format text in Microsoft FrontPage as you would using a word processor — to add visual organisation, emphasis, 
and structure. You can change the font, size, style, colour, spacing, and vertical position of text, and add effects such as 
underlining.

The formatting you apply can either affect selected words or an entire paragraph. A general rule is that font properties 
(such as font, size, colour, highlighting, and effects) can be applied to selected text, and paragraph properties (including 
bullets, numbering, shading, and borders) affect entire paragraphs. For example, you can italicise a single word in a 
paragraph, but if you try to align the word to the right, the entire paragraph will be aligned.

In this section, we are looking at Text formatting, we deal with Paragraph formatting in the next section

Formatting individual characters and words

Properties that you can set for words or characters include: 

•	 Font and font size (such as 10 point Tahoma, which can be applied to this entire page). 
•	 Effects, which include: 

1.	 Italics 
2.	 Underline 
3.	 Bold 
4.	 Strikethrough 

•	 Increasing or decreasing the space between characters to expand or condense your text.

This is an example of e x p a n d e d  text. 

This is an example of condensed text. 

•	 Raising or lowering text; for example, to indicate a footnote. You can also specify the number of points to 
raise or lower text. For example: 

There is a RAISED letter in this sentence. 
There is a LOWERED letter in this sentence. 

•	 Highlighting a word or an individual letter. 

To format individual characters or words
•	 Select the text
•	 Choose Format, Font

mk:@MSITStore:C:\Program Files\Office2K\Office10\1033\fpmain10.chm::/html/fpAboutFormattingText.htm##
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•	 Select the effect you want
•	 Choose Apply to see the effect

Or

•	 Choose OK to accept the effect

Changing character spacing and positions

To Change the spacing between characters
•	 Select the text you want to change. 
•	 On the Format menu, click Font, and then click the Character Spacing tab. 
•	 Do one of the following: 
•	 Expand or condense space evenly between all the selected characters
•	 Click Expanded or Condensed in the Spacing box, and then specify how much space you want in the By 

box.
•	 Kern characters that are above a particular point size
•	 Select the Kerning for fonts check box, and then enter the point size in the Points and above box.

Note: Selecting Expanded or Condensed alters the spacing between all selected letters by the same amount. Kerning 
alters the spacing between particular pairs of letters.

5.2	 Preview the Web in FrontPage preview

You can quickly preview the way your page will appear in your browser by clicking the Preview button at the button of 
the Page view window. This will display the page within the preview pane, which will render the page almost as if it were 
opened in your browser. To resume editing the page, click the Normal button to reopen the Normal pane 

To preview the web page in FrontPage preview
•	 Make sure you have the web page open
•	 Click the Preview button
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5.3	 Preview the Web in your Web Browser Application

It is, also, recommended to view your page in Microsoft Internet Explorer or whatever happens to be your default browser 
(e.g. Netscape). This can quickly highlight any problems. It must be said however that FrontPage 2002 is very intelligent 
and browser software these days is getting pretty standardised so you can probably trust FrontPage Editor Preview mode 
most of the time. To avoid problems, always save a page before previewing within FrontPage. 

To preview the web in your Web Browser
•	 Make sure you have a web page open.
•	 Save the page. If you don’t, FrontPage will prompt you.

•	 Click the Preview in Browser button on the toolbar.
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•	 Your default web browser opens and you see your web page exactly as you would see it, using this PC and 
using the browser that has activated - whatever server it is on and whether it were on an Intranet or the 
Internet.

•	 Switch back to FrontPage, keeping the web browser application open. Use the Windows Task bar.
•	 Make some changes to the web page.
•	 You must Save the page.
•	 Switch back to the web browser application
•	 Click the refresh button in your browser’s toolbar.
•	 The page re-generates to show the modifications you just made.

Note: You can automatically save a web page before previewing it in the browser. On the File menu, click Preview in 
Browser, and then select the Automatically save page check box. 

Note: If you are creating a Web site for public access, it is good practice to test the site in several versions of the most 
commonly used browsers. If you are designing your Web site for an Intranet and your company uses a single, standard 
browser, testing is less of an issue
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6	 Formatting Paragraphs
By the end of this section you will be able to:

•	 Change Alignments
•	 Use Indentations
•	 Apply Paragraph Spacing
•	 Apply Borders and Shading

We will turn your CV into 
an opportunity of a lifetime

Do you like cars? Would you like to be a part of a successful brand?
We will appreciate and reward both your enthusiasm and talent.
Send us your CV. You will be surprised where it can take you.

Send us your CV on
www.employerforlife.com
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6.1	 Paragraph Formatting

The following paragraph formatting options are available in FrontPage

•	 Paragraph Alignment
•	 Indentations
•	 Paragraph Spacing
•	 Borders and Shading

Set paragraph alignment

To Set paragraph alignments

•	 In Page view, select the text you want to align. 
•	 On the Formatting toolbar, click one of the following to align the text: 

Using Indentations

To Increase or decrease the left indent of an entire paragraph
•	 Select the paragraph you want to change. 
•	 On the Formatting toolbar, click Increase Indent  or Decrease Indent . 
•	 Microsoft Word increases the indent by one tab stop. If you want to change the position of the indent, you 

can first set a different tab stop. 

Applying paragraph spacing

To Change spacing before or after paragraphs
•	 Select the paragraphs in which you want to change spacing. 
•	 On the Format menu, click Paragraph, and then click the Indents and Spacing tab. 
•	 Under Spacing, enter the spacing you want in the Before or After box. 

http://bookboon.com/


Download free eBooks at bookboon.com

Click on the ad to read more

Frontpage 2003

58 

Formatting Paragraphs

Borders and Shading

To Add shading to text
•	 Select the paragraphs to which you want to add shading. 
•	 On the Format menu, click Borders and Shading…., and then click the Shading tab. 
•	 Do one or more of the following: 
•	 Set a background colour for the selected text
•	 Select a colour in the Background colour box.
•	 Set the colour of the selected text
•	 Select a colour in the Foreground colour box

To Add Border to text
•	 Select the paragraphs around which you want to add a border. 
•	 On the Format menu, click Borders and Shading. 
•	 Under Setting, click the Box icon. Set properties for the border by selecting options in the Style, Colour, 

and Width boxes
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7	 Using Bullets and Numbering
By the end of this section you will be able to:

•	 Create a Bulleted And Numbered List
•	 Change Bullets and Number styles
•	 Use images as bullets
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7.1	 Creating a Bulleted List

Lists are more effective than block text to get your points across. FrontPage provides for four different types of lists: 
number, bulleted, directory, and menu lists. Bulleted lists are most commonly used when creating web pages. You can 
create directory and menu lists from the Change Style drop-down list, while you can create numbered and bulleted lists 
by using toolbar buttons. To create a bulleted list, click the toolbar button, and then enter your items. Pressing [enter] 
twice at the end of the list discontinues the style.

To create a bulleted list:
•	 Click the Bulleted List   button from the Formatting Toolbar

Or

•	 From the Change Style drop-down list, select Bulleted List.
•	 Type your list items.
•	 Press [ENTER] twice at the end of the list to discontinue the style.

7.2	 Creating a Numbered list

To create a Numbered list:
•	 Click the Numbered List   button from the Formatting Toolbar

Or
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•	 From the Change Style drop-down list, select Numbered List.
•	 Type your list items.
•	 Press [ENTER] twice at the end of the list to discontinue the style.

Changing from a Bulleted or Numbered list

To change from a Bulleted/Numbered list
•	 In Page view, select the items in the list.
•	 On the Format menu, click Bullets and Numbering. 
•	 Do one of the following: 
•	 If the list uses bullets, on the Plain Bullets tab, click the box with no bullets. 
•	 If the list uses numbers or letters, on the Numbers tab, click the box with no numbering

Using images as bullets

To create a customised picture bullet
•	 In a graphics program, create a graphic to use as a bullet, and then save it, preferably in GIF or JPEG format. 
•	 Position the insertion point where you want to create a list. On the Format menu, click Bullets and 

Numbering, and then click the Picture Bullets tab. 
•	 Choose the Specify picture option button, and then click Browse to find and select the graphic you just 

created. 
•	 Click OK. 
•	 Type the text you want to add next to the bullet, and then press ENTER. 
•	 To end the list, press ENTER again. 

Note: When you save the page with the custom bullet, if the image you are using for the custom bullet is not in 
the current web site, you are prompted to save the bullet graphic, in GIF or JPEG format, to the current web site.

mk:@MSITStore:C:\Program Files\Office2K\Office10\1033\fpmain10.chm::/html/fpCreateBulletOrNumberList.htm##
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8	 Page Properties
By the end of this section you will be able to:

•	 Change the Page Title
•	 Change page background colour
•	 Use images as a background
•	 Use background sounds
•	 Change the margins
•	 Use Page Setup
•	 Use Page Transitions
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8.1	 Titling a Page

It is good design practice to give each page in the web a unique name that reflects the contents of that page. This is the 
page title. The title of a page is the name that appears in the title bar of most Web browsers and should be a user-friendly 
name. The title can be different from the file name - a friendly name; in any case, this is what the browser will see in the 
title bar of their browser.

For example, the title of your home page could be “My home page” even though the file name is index.htm. There are 
two methods of titling a web page

To assign a title to a page through the folder list
•	 In any view except Tasks or Reports view, right-click the file in the Folder List, click Properties on the 

shortcut menu, and then click the General tab. 
•	 In the Title box, type the title of the file that you want to appear in page banners and/or in your link bars. 

To assign a title to a page through page view
•	 Choose File Properties…..
•	 On the General page of the Page Properties dialog box, in the Title text box, type the name of the page.

Or

•	  Right-click the page.
•	 From the shortcut menu, choose Page Properties.
•	 Type the name of the page in the Title text box on the General tab of the Page Properties dialog box.

8.2	 Page Backgrounds

Web page backgrounds can be added very quickly to your web pages. All the pages in the web do not have to have the 
same background (image or colour). 

Setting Page Backgrounds colours

Many World Wide Web pages have grey backgrounds. This is because either black or white text is readable on a grey 
background. If you don’t want a grey background with black or white text, however, FrontPage gives you the option to 
change the colours of your page and text. You can also access this feature from the Page Properties dialog box on the 
Background page, shown below.

To set background colours
•	 Right mouse click on any part of the page
•	 Choose Page Properties…. Dialog box.
•	 Click on the Background tab.
•	 In the Colours Background drop-down list box, select the appropriate background colour.
•	 Choose OK.
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Setting Page text colours

To set text colours:
•	 Open the Page Properties dialog box as above.
•	 Click on the Background tab.
•	 In the Colours Text drop-down list box, select the appropriate text colour.
•	 Choose OK.

8.3	 Using Images as a background

You are not limited to solid background colours in FrontPage. You can use any image as a background for your document. 
There are many sites on the Internet from which you can copy and save background images and patterns for your personal 
use. Once you have saved these images to your hard drive, you connect them to your web through the Page Properties dialog 
box. By selecting the Background Image check box, you activate the Background Image text box. To connect the image 
with your web, either type the name of the image file in the text box or use the Browse button to locate your image file.

To add a background image
•	 Open the Page Properties dialog box.
•	 Select the Background tab.
•	 Select the Background Picture check box. 

•	 In the Background Picture text box, type the name of the image file or use the Browse button to find the 
image file.

•	 Choose OK.
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8.4	 Using Background Sounds

To add a background sound
•	 Open the Page Properties dialog box.
•	 Select the Background tab.
•	 On the Background page, select the Background Image check box.
•	 Type the sound file you want to play, or click Browse to locate the file. 
•	 Do one of the following: 
•	 To play the sound continuously, select the Forever check box. 
•	 To play the sound a fixed number of times, clear the Forever check box, and enter the number of times you 

want the sound to play in the Loop box. 

When a site visitor opens a page, the sound is played. 

Note: This feature is not supported by all Web browsers.

8.5	 Changing the Margins

To change the margins of your Web Page
•	 In Page view, right-click the page, and then click Page Properties on the shortcut menu. 
•	 Click the Margins tab. 
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•	 To set a top Margin: Select the Specify top margin check box. 
•	 Enter a value for the height of the margin in pixels. 
•	 Set a left margin: Select the Specify left margin check box. 
•	 Enter a value for the width of the margin in pixels. 

8.6	 Page Setup

To change the Page Setup options
•	 Choose File, Page Setup 

•	 Choose Options to change Print Setup options

mk:@MSITStore:C:\Program Files\Office2K\Office10\1033\fpmain10.chm::/html/fpSetPageMargins.htm##
mk:@MSITStore:C:\Program Files\Office2K\Office10\1033\fpmain10.chm::/html/fpSetPageMargins.htm##
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8.7	 Page Transitions

Page transitions in FrontPage are virtually identical to those in Microsoft PowerPoint and other graphical presentation 
applications. They add special effects to the pages in your web as they open or close.

To help you decide which type of transition effect to use, create one and preview it. The problem is that if you don’t have 
quite recent web browser software you won’t be able to view the transition. Neither, for that matter will people hitting 
your site. However, nothing will be lost on trying - no adverse effects will take place, so it could still be worth adding 
transitions even if you can’t see the effects they’re having. 

You can preview a transition effect in the FrontPage s Preview tab (if you have Microsoft Internet Explorer, version 4.0 
installed) or by choosing Preview in Browser on the FrontPage File menu (if you have Microsoft Internet Explorer, version 
4.0 or another Web browser that supports Dynamic HTML installed).

Page transitions are set by viewing the page you want to format in Page View and then launching the Page Transitions 
dialog box (shown above).

To apply a Page or Site Transition
•	 Open the page you want to format in Page View.
•	 Select Format, Page Transition.
•	 In the Page Transition dialog box, select an event (e.g. Page Enter).
•	 Select a transition.
•	 Select a time delay. This dictates how long the transition lasts.
•	 Click OK.

To Test a Page Transition
•	 Save the page you have just edited.
•	 Switch to Preview mode, by clicking on the preview button.
•	 Use a hyperlink to jump to another page in the web and then jump back to the page with the transition.

•	 If the transition did not work, check your browser capabilities
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9	 Inserting Images & Pictures
By the end of this section you will be able to:

•	 Inserting a horizontal line 
•	 Formatting a horizontal line
•	 Inserting clipart
•	 Inserting pictures from a file
•	 Adding a Photo Gallery
•	 Save images into your web
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9.1	 Inserting Horizontal Lines

FrontPage uses the command Insert, Horizontal Line to rapidly insert a standard line in to your web page. The reason 
for this is that web page designers often use a lot of lines in pages to separate text blocks. Remember that an attractive and 
easy to read look is absolutely imperative with web pages; much more so than with word-processed documents. Browsers 
will move on if your page looks boring or difficult to root out information quickly. 

To add a horizontal line
•	 From the Insert menu, choose Horizontal Line.

Formatting a Horizontal Lines

To format the Horizontal line
•	 Double-click the horizontal line, and then do one or more of the following:
•	 Under Width, specify the width of the line as a percentage of the window width or as a number of pixels. 
•	 Under Height, enter the height of the line in pixels. 
•	 Under Alignment, specify the alignment of the line on the page. 
•	 In the Colour box, select a colour for the line if you do not want a shaded line. 
•	 Select the Solid Line check box if you want the line to appear solid, and clear the check box if you want the 

line to appear shaded. 

Note: If you select a colour, the line will be solid, and you cannot apply shading. 

Note: If a theme is applied to the page, you can only change the alignment of the line.

9.2	 Adding Images (or Graphics)

Although image files for the web come in many formats, such as those shown below, the two most commonly used and 
supported formats for a web image are JPEG (Joint Photographic Experts Group) and GIF (Graphic Interchange Format). 
JPEG’s can support up to 24 million colours and are stored in a tightly compressed format so they take up minimal room 
on your server. Some of the picture detail is lost, however, to achieve the high rate of compression. On the other hand, 
GIF’s support only 256 colours and load faster. 

Extension Image File Format

.BMP Windows Bitmap

.EPS Encapsulated PostScript

.GIF Graphic Interchange Format

.JPG Joint Photographic Expert Group (JPEG)

.PCX PC Paintbrush

.TIF Tag Image File Format (TIFF)

.WMF Windows Metafile

mk:@MSITStore:C:\Program Files\Office2K\Office10\1033\fpmain10.chm::/html/fpAddHorizontalLine.htm##
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Inserting an Image

To insert an image, select Insert, Picture from the menu bar in Page View. The Image dialog box, shown below, lists image 
files that are already in your current web, and you can insert these files by simply selecting the desired image and choosing 
OK. You can also insert an image from a file (click the Select a File on Your Computer button) or from the World Wide 
Web (click the Browse WWW button). If you insert an image from the World Wide Web, the image is always accessed 
from its remote location and is not physically added to the current web, unless you save it to your web. 

To insert ClipArt
•	 Click the Insert Clip Art button on the Drawing toolbar. 
•	 The Microsoft Clip Organiser opens.
•	 Or, choose Insert, Picture, ClipArt from the menu bar.

To narrow your search, do one or both of the following: 

1.	 To limit search results to a specific collection of clips, in the Search in box, click the arrow and select the 
collections you want to search. 

2.	 To limit search results to a specific type of media file, in the Results should be box, click the arrow and 
select the check box next to the types of clips you want to find. 

•	  Double-click an image to insert it.

To insert an image from a file
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•	 In Page view, position the insertion point where you want to insert a graphic. 
•	 On the Insert menu, point to Picture, and then click From File. 
•	 Browse to the graphic you want from your local file system or web site, select the file, and click Insert. 
•	 You can specify the type of file you want to view in the Files of type box. 

Note: When you save the page, Microsoft FrontPage prompts you to save the graphic to your web site. Graphics that 
use 256 or fewer distinct colours are automatically converted to GIF, while all other graphics are converted to JPEG.

To Convert a graphic to a GIF or JPEG
•	 In Page view, right-click the graphic, and then click Picture Properties on the shortcut menu. 
•	 Click the General tab. 
•	 Under Type, click one of the following: 
•	 To convert the graphic to GIF format, click GIF. 
•	 To convert the graphic to JPEG format, click JPEG. 

9.3	 Adding a Photo Gallery

You can quickly and easily create a photo gallery to display personal or business photos or images. It is possible to add 
images to the photo gallery and select from 4 different customisable layouts. For effect, add captions and descriptions to 
images reorder images, change image sizes, and switch layouts.

To create a photo gallery
•	 Position the insertion point where you want to add a photo gallery. 
•	 Or, click to create a blank page.
•	 On the Insert menu, click Web Component. 
•	 In the left pane, click Photo Gallery. 
•	 In the right pane, select the type of layout you want to use. 
•	 A description of the selected layout appears below it. 
•	 Click Finish. 
•	 The Photo Gallery Properties dialog box automatically opens. 
•	 Click Add to insert a graphic into the photo gallery

Add a graphic to a photo gallery
•	 In Page view, double-click the photo gallery. 
•	 Click the Pictures tab. 
•	 Click Add. 
•	 Select one of the following: 
•	 Pictures from Files- 
•	 Locate the graphic you want to use, and click Open. 
•	 Pictures from a Scanner or Camera
•	 From the list, select the device from which you will be adding a graphic. 
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•	 If you want to make your graphic easily accessible the next time you want to use it, through the Clip 
Organiser (clip art), select Add to Clip Organiser. 

•	 Depending upon what type of device you selected, select Insert or Custom Insert. 
•	 Follow the directions for your specific device. 

To rearrange the order in which the photos or graphics will appear in the photo gallery, select the name of the graphic, 
and click Move Up or Move Down.

Saving Images into Your Web

It often confuses people that after they’ve inserted an image into a page, when they click File, Save to save the web page; 
FrontPage prompts them to Save Image to FrontPage Web (see below). This is because, so far, you have inserted an image 
into the page, but this is an image elsewhere on your PC, from the clip art library on the hard disk or from a network etc. 

When you save the page, FrontPage prompts you to save the image as a new file which will be part of the web in its own 
right. Therefore, after you’ve published the web the graphic can still be seen by people browsing your web – it’s no longer 
referencing a file on your PC but a file in the web. An icon representing the image appears in the web FrontPage Explorer.

Note: This is the case for any kind of image you’ve inserted, whether a background image or a graphic or a bullet 
image or horizontal line etc.

To Save an Image into Your Web
•	 After the image has been inserted, , click the Save button on the FrontPage standard toolbar
•	 In the Save Embedded Files dialog box, choose OK.
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10	 Connecting Pages
By the end of this section you will be able to

•	 Creating Hyperlinks to other pages
•	 Following Links
•	 Removing Hyperlinks
•	 Creating email hyperlinks
•	 Creating hyperlinks to external websites
•	 Creating Bookmarks
•	 Creating hyperlinks to bookmarks
•	 Using images as hyperlinks 
•	 Using hotspots on images to create hyperlinks 
•	 Hyperlinks View
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10.1	 Hyperlinks

What are hyperlinks

A hyperlink is a link from one web page or file to another. When a site visitor clicks the hyperlink, the destination is 
displayed in a Web browser, opened, or run, depending on the type of destination. The destination is frequently another 
web page, but it can also be a picture, a multimedia file, a Microsoft Office document, an e-mail address, or a program. 
Text hyperlinks are the most frequently used hyperlinks on the Web. Using FrontPage, you can easily create text hyperlinks 
that connect text in your web to another part of your web, to the World Wide Web, or to another Internet service such 
as FTP or Gopher. 

Remember, it is important to plan your hyperlinks as you are planning your pages. This helps you to map out how your 
web will be used. Refer again to the paper drawing of your web.

Creating hyperlinks

Hyperlinks can be created and edited in the Page View but pre-set buttons and links that form part of Navigation Bars 
must be edited in the Navigation View. An introduction to Navigation bars will be covered later in this section.

When you are creating a web, you will often find that you need to create a hyperlink to another open page in the web. 
You create hyperlinks to another page by using the Create Hyperlink dialog box.

After you create a hyperlink, as you navigate the page in the Preview window, if you point to the hyperlink with the mouse, 
the name of the hyperlinked (or Target) page appears in the status bar.

To create a hyperlink to an open page in the web:
•	 Open the file you want to link from, and select the text or object you want to make a hyperlink. 
•	 On the Standard toolbar, click Insert Hyperlink
•	 Under Link to, click Existing File or Web Page. 
•	 Locate and select the document that you want to link to. 
•	 To assign a ScreenTip to be displayed when you rest the mouse over the hyperlink, click ScreenTip and then 

type the text you want. 
•	 Word uses the path to the file name as the tip if you do not specify 
•	 Viewing Hyperlinks
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Following Links

•	 In Page view, right-click the hyperlink, and then click Follow Hyperlink on the shortcut menu. 

Remove a hyperlink

To remove a hyperlink
•	 In Page view, select the hyperlink. 
•	 Do one of the following: 
•	 Delete the hyperlink completely, including the hyperlink text
•	 Press DELETE. 
•	 Preserve the hyperlink text but delete the hyperlink associated with it
•	 Click Insert Hyperlink
•	 In the Insert Hyperlink dialog box, click Remove Link

Creating Email Hyperlinks

To create an email hyperlink
•	 Select the text or object you want to make a hyperlink. 
•	 On the Standard toolbar, click Insert Hyperlink
•	 Under Link to, click E-mail Address. 
•	 Either type the e-mail address you want in the E-mail address box, or select an e-mail address in the 

Recently used e-mail addresses box. 
•	 In the Text to Display box, type the label of the e-mail address you want to display on the link bar. 
•	 In the Subject box, type the subject of the e-mail message. 

Note: Some Web browsers and e-mail programs may not recognise the subject line. 

10.2	 Creating External Hyperlinks

One way of broadening the scope of your web is by creating hyperlinks to your favourite or most useful World Wide 
Web sites or to other Internet services

To creating Hyperlinks to external websites
•	 Select the text or object you want to make a hyperlink. 
•	 On the Standard toolbar, click Insert Hyperlink
•	 Under Link to, click make sure Existing File or Web Page is selected. 
•	 Choose one of the following
•	 (1)	 Select the page or file to which you want to link. 

Or

•	 (2)	 Select World Wide Web. 
•	 In your Web browser, browse to the page that you want to link to, and then press ALT+TAB to switch back 

to Microsoft FrontPage. The location of the page you visited is displayed in the Address box. 
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10.3	 Bookmarks

Creating Bookmarks

Bookmarks are placeholders in your documents. You can use them to move easily through your document without having 
to scroll through pages of information, and you can use them for creating hyperlinks within a page.

You create a bookmark by selecting the text you want to bookmark, and then opening the Bookmark dialog box, as shown 
right. FrontPage suggests a bookmark name based on the selected text. You can use this name or specify a different name 
for your bookmark by typing it in the Bookmark Name text box. After you choose OK to create the bookmark, the marked 
text becomes underlined with a dotted line.
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To create a bookmark:
•	 Select the desired text.
•	 Position the insertion point where you want to create a bookmark, or select the text to which you want to 

assign the bookmark. 
•	 On the Insert menu, click Bookmark. 
•	 In the Bookmark name box, type the name of the bookmark (spaces are allowed.) 

Note: If a location (rather than text) is book marked, the bookmark is indicated by . If text is book marked, the text 
is displayed with a dashed underline.

Linking to Bookmarks

Bookmarks allow you to create a hyperlink to other areas on the same page. When presenting a lot of text-based information 
on a page, you can create hyperlinks to section headers, glossary terms, or even to keywords.

If you are working with long text documents, it’s a good idea to keep all the text on one page and create bookmark 
hyperlinks. This is better than dividing the sections among several pages. Keeping a long text document on one page with 
bookmark hyperlinks makes it easier for users to print the information they want. If they have to keep going into page 
after page of the document, they can easily lose track of what they have already printed and what they have yet to print.

Again, the important issue here is that your pages must be easy to read. So the browser sees a few single descriptive text 
lines, each of which is a link to a bigger text block. As opposed to a mass of text that the reader has to trawl thorough to 
get the information he or she is looking for.
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To create a hyperlink to a bookmark:
•	 Open the page you want to go to and insert a bookmark. 
•	 Open the page you want to link from, and select the text or object you want to make a hyperlink. 

•	 On the Standard toolbar, click Insert Hyperlink  
•	 Under Link to, click Existing File or Web Page. 
•	 Locate and select the document that you want to link to. 
•	 Click Bookmark, and then select the bookmark you want. 
•	 To assign a ScreenTip to be displayed when you rest the mouse over the hyperlink, click ScreenTip and then 

type the text you want. 
•	 Word uses the path to the file including the bookmark name as the tip if you do not specify one.

10.4	 Image Hyperlinks

Creating an Image Hyperlink

Sometimes you will want to create an image hyperlink instead of a text hyperlink. Image hyperlinks can be easier for the 
user to understand since those images are often graphical representations of the documents to which you are linking. 
Graphical hyperlinks do not have to be pictures, however. They can also be objects, such as buttons, arrows, or icons, used 
to enhance the design of a page. Such images can be found in the Image dialog box, on the Clip Art page.

You create a hyperlink to an image just like creating a hyperlink to text; select the picture, and then open the Create 
Hyperlink dialog box and complete the process.

To create an image hyperlink:
•	 Select the image.
•	 On the Standard toolbar, click Insert Hyperlink  
•	 Select the appropriate button, bookmark or page command, depending on what you’re linking to.
•	 Click OK.

Using Hotspots

There might be times when you don’t want the whole image to be a hyperlink, or you might have a picture or graphic that 
you want to divide into two or more hyperlinks. A common example of this is a map where you want different hyperlinks 
on different countries. You can do this by creating hotspots, or small areas that activate a hyperlink when clicked with 
the mouse.

A hot spot is an invisible region on a graphic to which you have assigned a hyperlink. A text hot spot is a string of text that 
you have placed on a graphic and assigned a hyperlink. When a site visitor clicks the region or the text, the destination 
of the hyperlink is displayed in a Web browser. In Microsoft FrontPage, hot spots can be shaped as rectangles , circles , 
or polygons .

http://bookboon.com/


Download free eBooks at bookboon.com

Frontpage 2003

84 

Connecting Pages

You create a hotspot on a picture by selecting a shape tool from the Image toolbar, and then drawing a hotspot on the 
appropriate area on the picture. Hotspots can be rectangular, circular, or polygonal. After you’ve drawn the shape, you 
can create a hyperlink to the hotspot in the normal way. You can reveal the hotspots in your document by clicking the 
Highlight Hotspots button on the Picture toolbar. 

To create a hotspot:
•	 On the Picture toolbar, click the appropriate shape tool.
•	 Draw the shape on an image where you want to create the hotspot.
•	 The Create Hyperlink dialog box should open as soon as you release the mouse button.
•	 Create a hyperlink to the shape you’ve drawn.

To reveal the hotspots in your document:
•	 On the Picture toolbar, click the Highlight Hotspots button.

10.5	 The Hyperlinks View

Hyperlinks view presents a visual “map” of the hyperlinks to and from any page in your web. On the Views bar, click the 
Hyperlinks icon to switch to Hyperlinks view, and then in the Folder List, click the page you want.

In the illustration below, the user has hovered the mouse pointer over the surfers page and a label has appeared showing 
the name of the hyperlink (from Home to surfers.nfo.htm). A click on the plus sign (of the surfers page) will display the 
actual links in the window from the surfers page, thereby guiding you round the site on-screen by the hyperlinks. 
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Once this expansion has been made, the expand/collapse icon changes to display a minus sign; another click on the 
minus sign will collapse the level to the original situation. 

Note: Double clicking on any of the page icons (shown above right) will open the page in Page View as it will be 
assumed you want to work on that page.
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11	 Tables
By the end of this section you will be able to:

•	 Insert a table
•	 Enter and select Text
•	 Insert and delete rows and columns
•	 Change row heights and column widths
•	 Distribute rows and columns evenly
•	 Merge and Split Cells
•	 Apply borders and shading
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11.1	 Working with Tables

When creating web pages it is often difficult to get text to do what you want it to do. Although general text editing and 
spacing has become much easier in version 2002, it is sometimes still preferable to use tables. There are many new additional 
formatting features in 2002. This also makes your pages safer to view from different kinds, and versions, of web browsers. 
Table commands in FrontPage are similar to those in Word.

You can arrange text, images, and other page elements in rows and columns using tables, which are almost identical 
to tables in Word documents. Tables are a very effective way to organise information and enhance the appearance of a 
Web Page. They are potentially more important in Web pages than in Word documents because Web pages lack some 
of the other formatting features that are available for Word documents, such as multiple columns and tab characters for 
aligning text (the tab key just inserts spaces). Fortunately, when creating Web pages in FrontPage, you can use tables to 
accomplish many of the same effects

Inserting Tables 

Before you actually create a table, you need to decide how many rows and columns you want to include, where you want 
the table placed on the page, and how large the table should be. Once you have made these decisions, you can create 
your table by using the Insert Table dialog box, shown below. Using this dialog box, you can select the number of rows 
and columns, the alignment, the border size, the cell padding and spacing, and the width of the table across the screen. 
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To insert a table
•	 From the Table menu, choose Insert, Table.
•	 In the Insert Table dialog box, select the desired size, layout, and width options.
•	 Choose OK.
•	 Enter your data into the table.

Inserting and deleting rows and Columns

If you need to add more data to your table, you can insert rows and columns. To insert rows or columns, you use the 
Insert Rows or Columns dialog box, shown below. First, select whether you want to add columns or rows. You can then 
add any number of rows or columns to your table by typing in the number and choosing OK.

If you find your table is cluttered with unnecessary data, you can delete rows and columns. 

To insert rows or columns:
•	 From the Table menu, choose Insert then Rows or Columns.
•	 In the Insert Rows or Columns dialog box, select the Columns or Rows option button.
•	 Select the number of columns or rows.
•	 Select the position of the column, Left of the selection or Right of the selection.
•	 	Or
•	 Select the position of the row, Above selection or Below selection.
•	 Choose OK.
•	 In the new rows and columns, fill in the data.

Changing Row and Column Height

To change row Heights 
•	 Position the insertion point in a cell that is within a row you want to resize. 
•	 On the Table menu, point to Select and click Row. 
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•	 Right-click the row and then click Cell Properties on the shortcut menu. 
•	 To specify width, select the Specify width check box, select In pixels or In percent, and type a value for the 

width of the selected cell. 
•	 To specify height, select the Specify height check box, select In pixels or In percent, and type a value for the 

height of the selected cell. 

To change column widths
•	 Position the insertion point in a cell that is within a column you want to resize. 
•	 On the Table menu, point to Select and click Column. 
•	 Right-click the column and then click Cell Properties on the shortcut menu. 
•	 To specify width, select the Specify width check box, select In pixels or In percent, and type a value for the 

width of the selected cell. 
•	 To specify height, select the Specify height check box, select In pixels or In percent, and type a value for the 

height of the selected cell. 

Note: If the content (text, images, etc.) of a table or one of its elements is greater (bigger, longer, wider, etc.) than the 
specified value, the table or its elements will grow to accommodate that content. 

Distribute rows and columns evenly

If you have a table of varying row heights and column widths, you can equalise the width or height of selected rows or 
columns, in Page view, do one or both of the following: 

To make rows the same height
•	 Position the insertion point in a column whose rows are uneven. 
•	 On the Table menu, point to Select and click Column. 
•	 Right-click the column, and then click Distribute Rows Evenly on the shortcut menu. 

To make columns the same width
•	 Position the insertion point in a row whose columns are uneven. 
•	 On the Table menu, point to Select, and click Row. 
•	 Right-click, and then click Distribute Columns Evenly 

To delete the contents of a row or column:
•	 Select the row or column.
•	 From the Table menu, select Delete, Cells

To delete a row or column:
•	 Select the row or column.
•	 Right-click in the highlighted row.
•	 From the pop-up menu, choose delete cells.
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Splitting and merging cells

To spilt cells
•	 Right-click the cell you want to divide
•	 Choose Split Cells on the shortcut menu. 
•	 Choose Split into columns or Split into rows.
•	 In the Number of columns or Number of rows field, type the number of columns or rows into which you 

want the cells split

To merge cells
•	 Select a row, column, or group of adjacent cells. 
•	 Right-click, and choose Merge Cells on the shortcut menu. 

Note: This command is only available when two or more adjacent cells are selected, and the selected cells form a rectangle.

Applying Borders and Shading

To apply a border
•	 In Page view, do one of the following: 
•	 Select the paragraphs around which you want to add a border. 
•	 On the Format menu, click Borders and Shading. 
•	 Under Setting, click the Box icon. Set properties for the border by selecting options in the Style, Colour, 

and Width boxes. 
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To apply shading
•	 In Page view, do one of the following: 
•	 Select the paragraphs around which you want to add a border. 
•	 On the Format menu, click Borders and Shading. 
•	 Select the options you want, under the Shading tab. 
•	 Convert a table to text and text to table

To convert a table to text
•	 In Page view, click anywhere on the table that you want to convert to text. 
•	 On the Table menu, point to Select, and click Table. 
•	 On the Table menu, point to Convert, and then click Table To Text. 

Note: Each table cell will become a separate paragraph.

To convert a text to table 
•	 In Page view, click anywhere on the table that you want to convert to text. 
•	 On the Table menu, point to Select, and click Table. 
•	 On the Table menu, point to Convert, and then click Text to Table. 

Other Table Formatting options

Table Auto format
•	 This creates a quick and easy way to create a professional looking table in your web
•	 Click anywhere in the table whilst in Page view
•	 Choose Table, Table AutoFormat…… 
•	 Select from one of several table formats and designs to create the look you want

Table Fill
•	 This allows you to quickly repeat the contents of an individual cell to the right of the cell (Fill Right) or 

below the cell (Fill Down)
•	 Select the text you want to copy and the cells you want it to fill
•	 Choose Table, Fill
•	 Choose “Fill Down” or “Fill Right” to match the cells highlighted.

Table Spilt
•	 Table Split allows you to divide a table at any location quickly and easily. Very convenient for when you want 

to add text or graphics in between rows in a table.
•	 Pick a cell in the middle of the table, and then select Split Table from the Table menu.
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12	 Frame Sets
By the end of this section you will be able to:

•	 Create new pages using frames
•	 Add and remove frames
•	 Set the initial page
•	 Insert Inline Frames
•	 Create new pages for frames
•	 Save frame sets
•	 Change hyperlinks targets to frames or pages
•	 Change Margins
•	 Add a Page Border

http://bookboon.com/


Download free eBooks at bookboon.com

Frontpage 2003

95 

Frame Sets

12.1	 Introduction to Frames

Frames are a widely used feature of Internet and intranet sites. Frames divide a Web browser’s window into separate 
regions, each of which can display a separate, scrollable page. A group of frames is called a frames page. A frames page 
is a special Web page that defines the size and location of each frame it contains. 

In the simplest frames page there are two frames (see above): one frame displays a page listing a set of hyperlinks, and 
the other frame displays the pages to which the hyperlinks point. Each time a user clicks a hyperlink in the left frame, 
the page pointed to by that hyperlink is displayed in the right frame. The frames page itself does not actually contain any 
content or pages; it contains only hyperlinks to existing pages that are displayed in the frames.

You create a new frames page by selecting a frames page template from the Frames tab of the New dialog box. FrontPage 
creates the frames page in a new window in the FrontPage Editor. You then set the initial page you want displayed in 
each frame on the frames page.

How Frames work

In the example below, two frames are used. The first is the main page itself, showing eye-catching hyperlinks to different 
parts of the web. The second is the inner part that is scrollable, seen here as an entry form. The idea is that the user will 
fill out the form part of the page and that then changes. But the outer ‘frame’ remains constant so the user can, at any 
time, change his/her mind, leave the form for now, and go straight to a place of interest via the links displayed.
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Navigational Frames

In the second example below - again two frames, the web page uses a very common look. The main page frame is shown 
on the right, giving company information and opening information. On the left, the narrow, vertical frame contains 
hyperlinks to what is considered all the vital linked pages in the web the user may want to quickly jump to. This could 
be thought of as a navigational frame.

As the main frame on the right changes, according to what the user does, the navigational one on the left remains constant, 
showing the user the main links.

http://bookboon.com/


Download free eBooks at bookboon.com

Click on the ad to read more

Frontpage 2003

97 

Frame Sets

http://bookboon.com/
http://bookboon.com/count/advert/fba1fd82-96d7-e011-adca-22a08ed629e5


Download free eBooks at bookboon.com

Frontpage 2003

98 

Frame Sets

If you want to create a web page that has two frames, like the one in the example above, it actually means creating three 
separate web pages. This is because each page appears as a separate window because it is a separate page in its own right. 
That said, the FrontPage Frames Wizard will create the container page for you so really you only need two.

If you apply frames to an existing web, you’ll be adjusting page sizes so that when they are combined, two of the pages 
will appear as frames (or windows) inset in the main page. It would be a good idea to first design the look for the final 
page you have in mind. 

12.2	 Preparing to Create Frames

The collection of panes on one screen is called a frameset. Each frame has its own URL, so a site can be set up where you 
click a link in one frame and view the linked information in another frame on the same screen.

In Page View, you use the Frames Wizard to create a page with frames. 

Before actually using the wizard, explore the possibilities and plan the look of your web.

To start the Frames Wizard, first choose New from the File menu, and then choose Page or Web. Choose the Frames 
tab from the Page Template option as shown below
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This shows you some different variations of the framesets you can create. Look through them very carefully and consider 
which ones you might like to use and also how well they will fit with your site and existing pages. Now STOP, press 
CANCEL, and read on.

Considerations

•	 The idea of frames is that they should make it easier for users to navigate your site and keep their attention. 
Therefore, it’s possible that you can clutter up the screen with the more complex framesets.

•	 There may be users hitting your site whose browsers don’t support frames. This is becoming less and less 
likely but you might like to use them sparingly so as not to exclude any browsers.

•	 The more complex the frameset, the slower the page will run. There is no doubt about this at all because a 
frameset with three panes is effectively loading three separate pages (and any embedded objects)

•	 How would your site work with frames? Is it possible to classify all the linked pages in one table of contents? 
In other words would it make it neater to have one static frame with a table of contents (i.e. a list of 
hyperlinks) or would it confuse things and make navigation more awkward.

•	 Can you afford to lose the space that’s taken up when you merge pages in a frameset? Remember that if 
you have a static contents page on the left (as shown above), there is permanently a lot less space for you to 
spread out items on the page appearing in the frame on the right.

Preparing Pages

Basically there are two options open to you when creating a frameset:

•	 Convert your existing pages to pages ready to slot in to a new frameset
•	 Start from scratch and make new pages in the frameset as you go.

12.3	 Applying Frames to an Existing Web

In this scenario, you have designed a web and will already have a home page that is probably doubling as your contents 
page. In other words, it contains links to the other pages in your web.

Adapting Existing Pages for the Frameset

Make sure that you are happy with the idea of your home page (from now on this will be referred to as your index page) 
being the frame on the right of what will be the frameset. If you have links or buttons on this index page it might be a 
good idea to copy the index page (save it as Leftpage.htm for example) and then cut, paste and modify so that you begin 
to shape up the two component parts of the desired frameset.

Use the diagram below to fix your thoughts.
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In this case you would be using the method that follows.

To create a frameset within an existing web 
•	 In Page view, on the File menu, point to New, and then click Page or Web. 
•	 In the New Page or Web task pane, under New from template, click Page Templates. 
•	 Click the Frames Pages tab. 
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•	 Click a frames page template you want to use, and then click OK. 
•	 Set the initial page to show in each frame

Note: If View Page Frame appears on the left instead of Set Initial Page, click it and it should change to look like the 
example below.

To Set The Initial Page
•	 Click the frame whose initial page you want to set. 
•	 To select a page that is already created
•	 Click Set Initial Page in the frame, and then do one of the following: 
•	 Select the page from among the list of pages you have already created in the current working folder. 
•	 In the Look in box, locate the page you want to open. 
•	 Browse to the page you want to use by clicking. 
•	 In the Address box, type the URL of the page. 
•	 Create a new page and set it as the initial page to show in that frame
•	 Click New Page in the frame you want to set an initial page for. FrontPage creates a new page in the frame, 

and the new page is automatically set as the initial page. 

About inline frames

Inline frames are similar to frames pages except that the inline frame and its contents are embedded on an existing web 
page. Anything that you can put on a regular page you can put in an inline frame. Inline frames can also be customized 
in the same ways as regular frames.

One of the advantages of using inline frames is that you don’t need to create a separate frames page in order to have 
embedded content

How inline frames are used

You can use inline frames in a variety of ways:
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•	 To insert a contract for your site visitor to fill out 
•	 To give examples of what other web pages look like 
•	 As a container for a form 
•	 As a scrolling box with products and prices 

Add an inline frame to a page and set its properties
•	 In Page view, on the Insert menu, click Inline Frame. 
•	 Set the initial page of the inline frame.  
•	 To set a page which is already created

Click Set Initial Page in the frame, and then select the page you want to show.

•	 To Create a new page and set it as the initial page to show in that frame

Click New Page in that frame. Microsoft FrontPage creates a new page in the frame, and the new page is automatically 
set as the initial page. 

To set the properties of an inline frame
•	 Select the inline frame by moving the pointer to the top border of the inline frame until it changes to a left-

pointing arrow, and then click. 

•	 On the Format menu, click Properties. 

http://bookboon.com/


Download free eBooks at bookboon.com

Click on the ad to read more

Frontpage 2003

103 

Frame Sets
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•	 Set one or more of the following (if you don’t want to use the default values): 

Name  		  Type the name of your inline frame. 

Initial page   	 You can set or change the initial page of your inline frame. 

Frame size  	 Set the width or length of the frame in pixels or percentages. 

Margins   		 Set the margins of the frame in pixels. 

Alignment   	 Set the position for the inline frame on the page. 

Scrollbars   	 Set the scrollbars to Never appear, Always appear, or Appear if needed. 

Alternate text   	� Type the text that you want the browser to show in the event that the browser does not support 
frames. 

Show border   	 Select this check box if you want a border drawn around the inline frame. 

Note: Click the Style button (if it is available) to access other options for formatting your table using cascading 
style sheets as an inline style. 

12.4	 Save a frames page

A frames page is a special kind of HTML page that contains no visible content — it’s just a container that specifies which 
other pages to show and how to show them.

To save the frames page that holds the content:
•	 In Page view, with the frames page that you want to save open, click the Normal button. 
•	 On the File menu, click Save As. 
•	 The Save As dialog box displays a thumbnail showing the layout of the frames page. Because you are saving 

the frames page, or the frameset, all areas should have the dark blue box highlights indicating that this is 
what you are saving. 

•	 In the File name box, type a file name for the highlighted frames page. 
•	 To change the page title (that is, the text that you want to appear in the title bar of a browser), click Change 

title, and then in the Set Page Title dialog box, type the new page title.
•	 Navigate to the location where you want to save the page. 
•	 Click Save. 

Notes: After you have clicked Save, the Save As dialog box automatically opens again and asks you to save the page 
shown in the frame just saved. This occurs for each page shown in the current frames page. 

mk:@MSITStore:C:\Program Files\Microsoft Office XP\Office10\1033\fpmain10.chm::/html/fpAddIFrame.htm##
mk:@MSITStore:C:\Program Files\Microsoft Office XP\Office10\1033\fpmain10.chm::/html/fpAddIFrame.htm##
mk:@MSITStore:C:\Program Files\Microsoft Office XP\Office10\1033\fpmain10.chm::/html/fpAddIFrame.htm##
mk:@MSITStore:C:\Program Files\Microsoft Office XP\Office10\1033\fpmain10.chm::/html/fpAddIFrame.htm##
mk:@MSITStore:C:\Program Files\Microsoft Office XP\Office10\1033\fpmain10.chm::/html/fpAddIFrame.htm##
mk:@MSITStore:C:\Program Files\Microsoft Office XP\Office10\1033\fpmain10.chm::/html/fpAddIFrame.htm##
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Notes: The title shown in the title bar of the browser is the title of the frames page itself, not the title of the page 
displayed in the frame. 

Saving an individual Web frame

 It is also possible so save an individual Web Frame

To Save an individual Web frame
•	 Right-click in the frame you want to save as a Web page. 
•	 On the shortcut menu, click Save Current Frame As. 
•	 If you want to save the Web page in a different folder, locate and open the folder. 
•	 In the File name box, type a name for the Web page. 
•	 Click Save. 

12.5	 The Frames Page (or frameset) Properties

The properties of the frameset page can be edited just like ordinary frames but there are certain other properties that control 
items in the frame. For example, you can control whether a user can re-size the scrolling splitter between the two frames.

The properties for the frames page are controlled in the Frame Properties dialog box (shown below).

To activate the Frame Properties dialog box
•	 Make sure the frameset page is open in Page View.
•	 Right-click either frame.
•	 From the pop-up menu, choose Frame Properties.
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12.6	 Browsers that don’t Support Frames

As mentioned before in this section, it is becoming less and less likely that people will hit your site using Internet browsers 
that don’t support frames. But, nevertheless it does happen. If you are going to create a professional web site and you have 
taken the plunge to create a frameset as your home or index page, it is imperative that you make provision for browsers 
that don’t support frames.

FrontPage 2002 makes this a simple task for you by providing, by default, a backup ‘no-frames’ page. It is created 
automatically when you run the Frames wizard.

To Edit a no-frames’ backup page
•	 When you have created a frameset, make sure the Index page is open in Page View.
•	 Click the No Frames tab along the bottom of the screen (next to Normal view tab).

•	 Edit the page in the normal way. This page will be displayed if the browser does not support frames.

Note: This back up page will be affected by any Themes changes and can be edited whenever the Index (or host) page 
is open for editing. 

EADS unites a leading aircraft manufacturer, the world’s largest 
helicopter supplier, a global leader in space programmes and a 
worldwide leader in global security solutions and systems to form 
Europe’s largest defence and aerospace group. More than 
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exciting projects.
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learning and development opportunities, and all the support you need, 
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We welcome more than 5,000 interns every year across 
disciplines ranging from engineering, IT, procurement and 
finance, to strategy, customer support, marketing and sales. 
Positions are available in France, Germany, Spain and the UK.

To find out more and apply, visit www.jobs.eads.com. You can also 
find out more on our EADS Careers Facebook page.
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Create a hyperlink to show a page in another frame

Some of the content in this topic may not be applicable to some languages.

When you click a hyperlink on a page shown in one frame on a frames page, the page that the hyperlink points to usually 
opens in another frame, which is the target frame.

On frames pages that you create with frames page templates in Microsoft FrontPage, the target frames are already set up 
for you. You can override a target frame and choose a different frame where you want your hyperlink shown. 

To Create a hyperlink to show a page in a target frame
•	 Open the frames page you want to modify, click the Normal button, and then click the page where you want 

to create the hyperlink. 
•	 Type or select the text or picture you want to use as a hyperlink, and then click Insert Hyperlink. 

If you do not select text or a picture, the destination URL is displayed as the hyperlink text. 

•	 In the Insert Hyperlink dialog box, there are several ways you can select the page you want to show. 

Create a hyperlink to a page or file

Create a hyperlink to a page or file on the World Wide Web

Create a hyperlink to an e-mail address

Create a hyperlink to a bookmark

Create a hyperlink to a new page
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13	 FrontPage Components
By the end of this section you will be able to:

•	 Create a Marquee
•	 Create Banner Adds
•	 Create Hit Counters
•	 Create Hover Buttons
•	 Create scheduled Pictures
•	 Use Dynamic HTML effects in text
•	 Insert Dynamic Charts, Pivot Tables and spreadsheets
•	 Insert Video and media files
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13.1	 FrontPage Web Components

Using FrontPage Components

There might be times when you want your web to do more than just passively present information to your user. For 
example, you might want to make your web more interactive. You can make this happen by programming commands 
in HTML, but this can be complicated and time-consuming. Instead, FrontPage has done the programming for you by 
creating Components (Referred to as Web Bots in previous versions of FrontPage).

Identifying FrontPage Components

Components are small groups of procedures, or handlers that execute a certain sequence of events. FrontPage has 
Components that let you collect information, search your web, create a table of contents, hide things from view, and 
perform other functions. Components and their functions are described in the table below. 

Component Function

Comment
Used as markers to remind you of jobs that needs to be done on parts of 
pages. These can be left on the page as they are not seen in Preview mode or 
by browsers.

Document Library View
Displays the contents of a document library on a Share Point Team Web Site. 
You can insert this component only if you’ve opened a web stored on a Web 
server running Share Point Team Services

Dynamic Effects

Hover Button: Displays a visual effect or plays a sound when you move the 
pointer over the button, or (for a sound) when you click the button so that 
clicking it will open the hyperlink target

Marquee: Displays text that scrolls horizontally across the page.

Banner Ad Manager: Runs a “slide show” displaying a series of images. You 
can control the amount of time each images is shown and select a transition 
effect that occurs when images are switched

Hit Counter
Keeps track of and displays the number of times someone has opened the 
page

MSN

Look up a Stock Quote: Obtains and displays stock quotes from the Money 
Central Web site.

Search the Web with MSN: Lets the visitor perform a Web search using 
Microsoft Network.

MSNBC Components
A Set of components that obtain and display news and weather information 
from the MSNBC Web site

Photo Gallery 
Displays a collection of images, automatically generating thumbnail images 
for each.
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Spreadsheets and Charts

Office Chart: Charts data hat you enter or data obtained from a database in a 
column, bar, line, pie, or other type of chart

Office Pivot Table: Displays data from a database in an interactive pivot table

Office Spreadsheet: Displays the data you enter in a spreadsheet that the 
visitor can view or edit

Top 10 list
Components that display web usage statistics in the form or top-10 lists: 
the 10 most visited pages in the web, the 10 most common referring visitor 
domains, the 10 most common visitor browsers, and so on

Web Search
Current Web: Generate a form that lets the user search through all the text on 
the pages of your web. The search results are displayed as a list of hyperlinks 
to the pages that contain matching text.

Creating a marquee

To Create a marquee
•	 In Page view, click where you want to create the marquee, or select the text that you want to display in the 

marquee. 
•	 On the Insert menu, click Web Component. 
•	 In the left pane, click Dynamic Effects. 
•	 In the right pane, double-click Marquee. 
•	 In the Text box, type the line of text you want the marquee to display. If you selected text on the page in step 

1, the Text box contains the selected text. 

You can format a marquee to adjust its direction and speed, behaviour, alignment, size, number of repetitions, and 
background colour. 

You can format the font in a marquee to adjust font size, style, colour, and character spacing. 

Creating a banner ad

To Create a banner ad
•	 In Page view, in the Normal pane, position the insertion point where you want to create a banner ad. 
•	 On the Insert menu, click Web Component. 
•	 In the left pane, click Dynamic Effects. 
•	 In the right pane, double-click Banner Ad Manager. 
•	 For each picture you want to display in the banner ad, click Add, and then select the picture. 

The list in the Pictures to display box shows the pictures you added and the sequence in which the pictures 
will be displayed. 

•	 To change the sequence, select the URL of a picture in the list, and then click Move Up or Move Down. 
•	 In the Transition effect box, select the effect you want to use between pictures. 
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•	 To create a hyperlink from the banner ad, in the Link to box, type a URL. Or, click Browse to locate the 
destination page or file for the hyperlink. 

Note: The images you use to create a single banner will all link to the same URL. If you want some of your pictures 
to link to another URL, repeat steps 1 through 8 to insert another banner ad.

Inserting the Hit Counter Component

The Hit Counter is a tool for you to see how many people have hit your web site. To insert a Hit Counter Component, 
click the Insert FrontPage Component button, shown right, on the Editor Toolbar. This opens the  Insert FrontPage 
Component dialog box (shown below-left). In this dialog box, you select Hit Counter and choose OK.

Then, in the Hit Counter Properties dialog box, shown below-, select the counter style and reset the counter to a number 
of your choice. Use this if you want to disguise the fact that your site is new. Then choose OK. A hit counter marker 
appears in your web page.

We will turn your CV into 
an opportunity of a lifetime

Do you like cars? Would you like to be a part of a successful brand?
We will appreciate and reward both your enthusiasm and talent.
Send us your CV. You will be surprised where it can take you.

Send us your CV on
www.employerforlife.com
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Creating a hover button

•	 In Page view, in the Normal pane, position the insertion point where you want to create a hover button. 
•	 On the Insert menu, click Web Component. 
•	 In the left pane, click Dynamic Effects. 
•	 In the right pane, double-click Hover Button. 
•	 In the Button text box, type the text label for the hover button. 
•	 If you want to use a custom picture that already contains a text label, clear the default value. 
•	 In the Link to box, type the URL of the page or file you want to display when the hover button is clicked. 

Or, click Browse to locate the page or file. 

Note: To preview the hover button as it will appear when a site visitor browses to the page on the World Wide Web, 
click the Preview button, or click Preview in Browser on the File menu. 

Scheduling a web page or picture to appear at a specific time

You can set a page or picture to be displayed on another page during a specific time period. This feature is useful for 
time-sensitive content. For example, you can display a special advertisement during a holiday weekend.

You can also specify a page or picture to be displayed outside of the time period; for example, you can specify a regular 
advertisement to be displayed before and after the holiday weekend

13.2	 Display a web page or picture at selected times

You can set a page or picture to be displayed on another page during a specific time period. This feature is useful for 
time-sensitive content. For example, you can display a special advertisement during a holiday weekend.

You can also specify a page or picture to be displayed outside of the time period; for example, you can specify a regular 
advertisement to be displayed before and after the holiday weekend

To display a web page or picture at selected times
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•	 In Page view, position the insertion point where you want to display another page or picture. 
•	 On the Insert menu, click Web Component. 
•	 In the left pane, click Included Content. 
•	 In the right pane, double-click either Page Based on a Schedule or Picture Based on a Schedule. 
•	 Do one or more of the following: 
•	 In the During the scheduled time box, type the relative URL of the page or picture to include, or click 

Browse to locate it.
•	 To specify a page or picture to display outside the specified time period, in the Before and after the 

scheduled time box, type the relative URL of the page or picture you want to include, or click Browse to 
locate it. 

•	 In the drop-down boxes after Starting, specify the year, month, day, and time at which you want to start 
displaying the page or picture. 

•	 In the drop-down boxes after Ending, specify the year, month, day, and time at which you want to stop 
displaying the page or picture. 

Note   The web server’s clock is used to determine the time period.

13.3	 Inserting Excel Charts, Pivot Tables and spreadsheets

If you want to create a chart for your web, you can add a Microsoft Office Chart component to a page. You can then directly 
edit and set properties for the chart in Page view, even if you don’t have Microsoft Excel installed on your computer.

To insert an Excel Chart
•	 On the Insert menu, point to Component, and then click Office Chart. 

Note: When you include an Office Chart in your web, a site visitor will need to have the Microsoft Office Web 
Component controls installed on her/his computer to view the chart. (If the controls are not installed, a site visitor 
will see a watermark.) A site visitor must have Microsoft Office installed on her/his computer, or have access to a 
Microsoft Office installation server to have the controls. 

A Microsoft Office PivotTable list is an interactive table that displays summary data from a database or other source. If 
you want to create a PivotTable list for your web, you can add an Office PivotTable component to a page. You can then 
directly edit and set properties for the Office PivotTable in Page view, even if you don’t have Microsoft Excel installed on 
your computer. 

To insert an Excel Pivot Table
•	 On the Insert menu, point to Component, and then click Office PivotTable. 

Note: When you include an Office PivotTable in your web, a site visitor will need to have the Microsoft Office Web 
Component controls installed on her/his computer to view the PivotTable. (If the controls are not installed, a site 
visitor will see a watermark.) A site visitor must have Microsoft Office installed on her/his computer, or have access 
to a Microsoft Office installation server to have the controls. 
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Browser versions that support DHTML 

While DHTML effects work with Microsoft Internet Explorer 4.0 or later and Netscape Navigator 4.0 or later, most of 
these effects appear static (not animated) when viewed in version 3 Web browsers.

Browser Version DHTML Support

Internet Explorer 5.0 and later Yes

Internet Explorer 4.0 and later Yes

Internet Explorer 3.0 and later No

Netscape Navigator 5.0 and later Yes

Netscape Navigator 4.0 and later Yes

Netscape Navigator 3.0 and later No

Both Internet Explorer and Netscape Navigator 4.0 and later Yes

Both Internet Explorer and Netscape Navigator 3.0 and later No

Microsoft WebTV  No

Turning DHTML on or off

If site visitors with older browsers (Microsoft Internet Explorer 3.0 or earlier or Netscape Navigator 3.0 or earlier) make up 
a large portion of your audience, you can turn off DHTML features using the Microsoft FrontPage browser compatibility 
settings.
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If you disable DHTML, or if you design a web site to be compatible with a browser that doesn’t support DHTML, the 
commands that use DHTML will be unavailable (that is, they will appear dimmed) on menus in FrontPage.

The following commands and settings are unavailable when DHTML is disabled:

•	 Dynamic HTML Effects (Format menu) 
•	 Page Transition (Format menu) 
•	 Enable collapsible outlines (Bullets and Numbering dialog box) 
•	 Enable hyperlink rollover effects (Page Properties dialog box, Background tab) 

Note: If you choose a browser compatibility selection that doesn’t support DHTML, but use it anyway, your pages 
might not be displayed properly, or they might contain errors
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14	 Using Frontpages Themes
By the end of this section you will be able to:

•	 Applying themes to Pages or all documents
•	 Removing Themes
•	 Viewing Themes Formatting and navigation bar features
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14.1	 FrontPage 2002 Themes

Users of Microsoft PowerPoint will be familiar with presentation templates that apply a certain look across an entire 
slideshow presentation. FrontPage allows you to do the same. By choosing a theme you choose a standard look that will 
be applied across the existing web and any new pages you create within it.

Themes add a special look to all your web pages. They also add tables, navigation bars, buttons and links. Applying a 
theme may well spoil the look of some of your page objects. However, after a theme has been applied you can of course 
go back and change backgrounds and buttons and any page(s).

Viewing Themes

To view the FrontPage Themes
•	 Click the OK button to apply the theme across your web.
•	 Switch to Folders view.
•	 Double click a page to open in Page View.
•	 View the web pages with the theme in the Normal and Preview modes.

Removing a Theme

A theme can be instantly removed from your web.

To Remove a Theme
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•	 Go to Format Theme
•	 Click the This Web Does Not Use Themes options button, above the Themes selection window. 
•	 Click the Apply button.
•	 All themes are removed from the entire web. 
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15	 The Naviation Bar
By the end of this section you will be able to:

•	 Inserting a standard navigation bar using text and buttons
•	 Navigation Bar properties
•	 Links to home pages
•	 Creating parent and child
•	 Removing the navigation bar
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15.1	 Navigation Bars

Introduction

Navigation bars are automatically added with themes or can be added manually in the FrontPage Editor. They are clusters 
of buttons and/or icons that link the page to other web pages on the web, but only those that are part of a structure in 
Navigation view. 

To change the button labels or hyperlinks on a Navigation Bar it is necessary to switch to the Navigation view.

15.2	 Navigation View

To switch to the Navigation window, click the Navigation button on the Shortcut bar. 

The Navigation view shows the structure of the web as it exists in levels. This is best understood in terms of an organisational 
chart. The simplest levels are parent and child. In all cases the Home page will be at the top of the structure - at parent 
level. But there may be other pages on this same level (at parent level). Any sub pages or pages you can think of that 
might stem from the home page (for example in a domestic family web site the home page would introduce the family 
and each family member would have a sub home page introducing themselves) exist at child level.

In a multi tiered web site you could visualise yourself having, on any one page, links to other pages on the same level, 
pages at parent level (pages linked directly above) and pages at child level, that is pages linked directly below. 

In the illustration below the organisational structure in the upper pane shows the levels in the web. The home page is 
on the top level. If you focus on that page, it has three pages on the same level and three pages at child level. It has no 
parent pages.

If you focus on the Products page, it has four parent pages (one direct), two pages at the same level and three child pages.
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This concept is only perhaps only useful if you are going to use banners and Navigation Bars in your web.

Creating New Pages in the Navigation Window

If you want to preserve the Child/Parent structure of your web, you can easily add pages in the Navigation view, thereby 
controlling the tiered structure. Pages are added at child level to that which is selected.

To insert a new page in the Navigation window
•	 Make sure you have your web open in Navigation View.

•	 Right-click the page you want to create a child page for.
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•	 Select New Page from the drop down sub menu OR press the icon on the toolbar (shown right).
•	 A new page is added as a child to the page you right-clicked on.
•	 Right-click the new page and select Rename from the drop down sub menu.
•	 Rename the new page.

Navigation Bars

In Section 3 you looked at the Navigation view. Once this structure has been set up, you can insert a very useful Navigation 
Bar component which updates automatically as you add new pages, delete pages, and rename them, whatever. To change 
the hyperlinks or button labels on a navigation bar, use the Navigation View in the FrontPage Explorer and rename the 
page title you want to change.

The best thing about using Navigation Bars in FrontPage is that they can be reconfigured and re-pointed very easily 
without having to physically edit hyperlinks in the FrontPage Editor.

Inserting a Navigation Bar
•	 Create a navigation structure (see above). 
•	 In Page view, position the insertion point where you want to place the link bar. 
•	 On the Insert menu, click Navigation Bar. 
•	 In the right pane, click Bar based on navigation structure, and click Next. 
•	 Select the link bar style you want to use for this link bar. Or, if your page uses a theme, click Use Page’s 

Theme. 
•	 If a theme has been applied to your web site, button link bars will use fonts, colours, and other style 

elements from the theme. If you click Use Page’s Theme and your page does not use a theme, the link bar 
will use the default text of the page. 

•	 Click Next. 
•	 Choose the page orientation of the link bar (vertical or horizontal), and click Finish. 
•	 Under Hyperlinks to add to page, select the type of hyperlinks you want on the link bar, and click OK. 
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Using the above dialog box you can set the Navigation Bar Hyperlinks to include:

Parent Level
Choose this option to include hyperlinks to the other page(s) on the same level as the 
parent page.

Same Level
Choose this option to include hyperlinks to the other page(s) on the same level as the 
active page.

Back and Next
Choose this option to include hyperlinks to the adjacent page(s) on the same level as the 
active page.

Child Level Choose this option to include hyperlinks to the page(s) below the level of the active page.

Top Level
Choose this option to include hyperlinks to the page(s) on the same level as the home 
page.

Additional Pages:

Home Page Select this option to include a hyperlink to the home page.

Parent Page Select this option to include a hyperlink to the parent page

Note: The navigation structure for the link bar is determined by the order of pages in Navigation view. 

Changing the Orientation of a navigation bar

To Change the format of a link bar that uses buttons
•	 In Page view, double-click the link bar. 

•	 Click the Style tab. 
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•	 Select the link bar style you want to use for this link bar. Or, if your page uses a theme, click Use Page’s 
Theme. 

•	 If a theme has been applied to your web site, button link bars will use fonts, colours, and other style 
elements from the theme. If you click Use Page’s Theme and your page does not use a theme, the link bar 
will use the default text of the page. 

Note: If you change a link bar in a shared border, the change will affect all pages using that shared border.

Removing the navigation bar

To remove the navigation bar
•	 Select the Navigation bar by clicking on it 
•	 Press the Delete button
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16	  Shared Borders
By the end of this section you will be able to:

•	 Setting web shared borders
•	 Setting page only shared borders
•	 Using shared borders
•	 Removing Shared Borders
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16.1	 About Shared Borders

A shared border is a region on a web page that is common to one or more pages in a web site. A shared border may be a 
region at the top or bottom of the page (similar to a page header or footer), at the left, or at the right. Use shared borders 
to place the same content on multiple pages in one step, rather than editing each page.

For example, to quickly place a logo at the top of each page in your web site, design your pages so that they all have the 
same top border, then add the graphic to that top border.

16.2	 Ways to use shared borders

Shared borders are a quick and easy way to give your pages a consistent look. After you set a shared border, you can add 
content to it. At any point, you can change or remove the content in a shared border. Following are examples of ways to 
use shared borders: 

•	 Add a page banner to ensure that each page has a title 
•	 Add the company logo 
•	 Add a link bar to let site visitors get to the main pages in your web site 
•	 Add a copyright notice 
•	 Add the date and time the web site was last modified 
•	 Add an e-mail address for feedback, such as the Webmaster’s address 

Note: If you add page banners and link bars in a shared border, the pages must be added to Navigation view in order 
to be displayed correctly.

Setting up web shared borders

To set up a shared border
•	 On the Format menu, click Shared Borders. 
•	 Click All pages. 
•	 Select the borders that you want to appear on every page in the current web site. 

Note: If you select Top, Left, or Right, you can also choose to include link bars. Dashed lines are displayed to indicate 
the shared border, and you can now add the content you want. 

Note: If you included a link bar (and then added the page to Navigation view), it is displayed in the shared border. 
Otherwise, a comment is displayed telling you to add content. To remove the comment, select it, and then press 
DELETE. 

Set shared borders for a page

•	 On the Format menu, click Shared Borders. 
•	 Click Current page. 
•	 Specify the borders that you want on this page. 

Note: To remove the comment telling you to add content, select it, and then press DELETE.

mk:@MSITStore:C:\Program Files\Office2K\Office10\1033\fpmain10.chm::/html/fpAboutSharedBorders.htm##
mk:@MSITStore:C:\Program Files\Office2K\Office10\1033\fpmain10.chm::/html/fpSetSharedBorders.htm##
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Using Shared borders

When you use shared borders, you only have to modify content in one place to update all pages. For example, to change 
the copyright notice on each page of a 30-page web site, you can update it only on one page if the notice is inside a shared 
border.

Removing Shared Borders

•	 On the Format menu, click Shared Borders…. 
•	 Ensure that All Pages is selected
•	 Ensure that Top, Bottom, Left, Right are all deselected. 
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17	  Table of Contents
By the end of this section you will be able to:

•	 Creating a Table of Contents
•	 Updating a table of contents
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17.1	 Create a table of contents

To create a table of contents
•	 Create a table of contents based on the navigation structure
•	 In Page view, position the insertion point where you want to create a table of contents. 
•	 On the Insert menu, point to Web Component. 
•	 In the left pane, click Table of Contents. 
•	 In the right pane, click For This Web Site, and then click Finish. 
•	 In the Page URL for starting point of table box, type the relative URL of the page to use as the starting 

point for the table of contents, or click Browse to locate the page. 
•	 The starting point determines which pages are leftmost in the table of contents. Pages pointed to by 

hyperlinks on the starting page will be indented one level in the table of contents. 
•	 In the Heading font size box, select the paragraph style for the heading (the top-level entry, or starting 

page) of the table of contents. To exclude the starting page from the table of contents, click None from the 
drop-down list. 

•	 Under Options, do one or more of the following: 
•	 Select the Show each page only once check box if your web site includes pages pointed to by multiple 

hyperlinks and you want the table of contents to list each page only once. 
•	 Select the Show pages with no incoming hyperlinks check box to include pages not pointed to by any 

hyperlinks in your web site. 
•	 Select the Recompute table of contents when any other page is edited check box to automatically 

recalculate the table of contents whenever any page in your web site is edited. 

Note: Recalculating a table of contents for a large web site can be a time-consuming process. If you select this check 
box, you may find that it takes longer to save pages. If you don’t select this check box, you can manually regenerate 
the table of contents by opening and saving the page containing the table of contents.

17.2	 Regenerate a table of contents 

You can create an automatically generated table of contents based on the navigation structure of your web. A site visitor 
browsing your web can click any entry in the table to jump to that page or file. Use this procedure to automatically 
recalculate the table of contents whenever any page in your web is edited. 

To update a table of contents
•	 In Page view, right-click the table of contents you want to modify, and then click Table of Contents 

Properties on the shortcut menu. 
•	 Select the Recompute table of contents when any other page is edited check box. 

Note: Recalculating a table of contents for a large web can be a time-consuming process. If you select this check box, 
you may find that it takes longer to save pages. If you don’t select this check box, you can manually regenerate the 
table of contents by opening and saving the page containing the table of contents.
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18	  Online Forms
By the end of this section you will be able to:

•	 Create an online form
•	 Form Wizard
•	 Creating Forms within tables
•	 Inserting and naming form components
•	 Sending results to text file or email
•	 Changing the text results name
•	 Adding a confirmation page
•	 Creating custom confirmation page
•	 Including additional fields in results
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18.1	 Introduction to forms

What are Forms

Forms are items used by people who want to interact with your web. This can mean many things; you may want to collect 
information about people hitting your web site, you might need a bulletin board in the web so users can leave messages or 
contribute to discussions, you may want to collect information from users that can be fed into other Office applications, 
for example data storage in Excel or a data file for mail merge in Word.

Many web sites these days take orders on-line, this is done with forms.

In this section you will learn how to design forms and use the pre-set FrontPage form templates and ultimately defining 
the Input Target (the file and location thereof for storing the information collected from the user).

A form consists of a collection of fields (sometimes known as controls) – such as text boxes, check boxes, and push buttons 
– that are used to collect information from visitors to your web page. Each form normally includes a Submit button that 
the user clicks after filling in the fields to transmit the information, plus a Reset button that the user can click to clear all 
fields prior to entering new information.

The figure shows a sample form as it appears in Microsoft FrontPage

The figure below shows the same form displayed in Microsoft Explorer
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The figure below shows the same form displayed in Microsoft Explorer

To Create a form on your own
•	 On the Insert menu, point to Form, and then click Form. 
•	 Add form fields. 
•	 On the Insert menu, point to Form, and then select the fields you want to add to your form.

Create a form using a wizard
•	 On the File menu, point to New, and then click Page or Web. 
•	 In the New Page or Web task pane, under New from template, click Page templates. 
•	 On the General tab, click Form Page Wizard, and then click OK. 
•	 Follow the on-screen instructions to complete the form. 

18.2	 Designing Forms

Designing your feedback forms requires adding form controls. All these are available on the Forms toolbar.

Using Form Controls

Controls are objects that require some sort of user input or action. You may already have used them in other Microsoft 
products, for example drop down (or combo) boxes in Access, options (or radio) buttons in Excel or text boxes in Word…
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Check Box’s

To place a check box in your form
•	 Make sure you have web page open in Page View 
•	 Decide what the question is to be for the check box option.
•	 Click in a line in the page or in a table cell.
•	 Make sure the Forms toolbar is active. If not, select View, Toolbar Forms.

•	 Click the Check box  icon. 

•	 Type a question for the user to check or uncheck.
•	 Right-click the new check box and select Form Field Properties from the shortcut menu. 
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•	 In the Check Box Properties dialog box, rename the object. For example My Check Box or Check Box 1 or 
something that reflects the question alongside it. 

•	 Select a Default Initial State for the box. This is how it will appear when the user opens the form.
•	 Click OK

Radio buttons

These normally appear in clusters. For example VISA, MASTERCARD, or AMEX. The idea of options buttons is that 
only one option must be selected. 

To place an Radio Button check box
•	 Make sure you have a page open in Page View.
•	 Decide what the options text labels are going to be.
•	 Click in a line in the page or in a table cell.

•	 Choose Insert, Form, Option Button 
•	 Type the option alongside it.
•	 Right-click the new Radio Button and select Form Field Properties from the shortcut menu. 
•	 In the Radio Button Properties dialog box, rename the Group Name. Your other Radio buttons within the 

same group must be given the same group name. For example Credit Card Choice or something that reflects 
the use of the group of buttons.

•	 Select a default Initial State for the button. This is how it will appear when the user opens the form.
•	 Click OK

Note: Click Validate to open the Radio Button Validation Dialog Box. Use this dialog box to require a user to choose 
an option from a group of options by selecting a radio button.

One-line Text Boxes

To place a text box in your form
•	 Make sure you have a page open in Page View.
•	 Decide what the text box label will be
•	 Click in a line in the page or in a table cell.
•	 Type a text label or a question that will prompt the user to type text in a text box alongside it
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•	 Choose Insert, Form, Text Box

•	 Right-click the new Text Box and select Form Field Properties from the shortcut menu. 
•	 In the Text Box Properties dialog box, rename the box. For example Address1 or Surname, something that 

reflects the information requested by you.
•	 Consider whether it is worth limiting the size of characters that can be entered into the field.
•	 Click OK.

Note: The names of all these buttons and boxes are not displayed for the user. They are for your own information as 
tags against information retrieved from the form after it’s been submitted. Choose friendly names to help you see what 
information comes from which question.
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Note: Take very special care to name a text box label logically. This is because there may come a time when you want 
to export feedback data to another application for use in a database. For example, addresses might be better asked 
for as Address1, Address2, City etc.

Drop Down Menus

Drop down menus are more useful than Radio Buttons if more than one option is to be selected. This is done by holding 
the [CTRL] + click to choose more than one (adjacent or non-adjacent). This should be noted near the drop down box 
on the page if you think users will want to do this and you suspect they will not guess that it’s possible.

To place a drop down menu
•	 Make sure you have a page open in Page View.
•	 Decide what the drop down menu label will be.
•	 Click in a line in the page or in a table cell.

•	 Type a text label or question that will prompt the user to select an option from the drop down box.
•	 Choose Insert, Form, Drop-Down box

•	 Right-click the new drop down menu and select Form Field Properties from the shortcut menu
•	 Type a name for the drop down menu itself, in the Name field. This is the name for all the options. Ideally, 

for your later reference, it should match the text label or question alongside it.
•	 Prepare to add an option to the drop down menu. Click Add. 
•	 Enter a name for the first option or Choice to appear in the menu in the Choice field. This is the text choice 

the form user will see in the drop down menu.
•	 Choose between Selected or Not Selected as the default option in the menu when the form opens and the 

user tabs to it.
•	 Click OK. You will see your choice in the list.
•	 Click Add and add another choice in the same way.
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•	 Click OK.
•	 You may promote or demote each choice in the menu by clicking the Move Up or Move Down buttons, 

having clicked on a choice you want to move.

Submitting the Form

Once you have created all your input controls the final aspect of design is to allow the form to be submitted. Additionally, 
most web forms have a means of re-setting too, in case of mistakes.

Adding Submit and Reset Buttons

These buttons are created from the Push Button option on the Forms toolbar.

Note: common web design standards dictate that the Submit and Reset buttons should appear side by side and with 
the Submit button on the left.

18.3	 Managing Form Results

Setting Form Properties

At any time when you are designing and editing the form you can go to view the properties for the form itself, as opposed 
to individual items on it. 

This is the area where the storage location is chosen for the information gained from submitted forms. This will be covered 
in more detail in this section.

To display the Form Properties dialog box.
•	  Right-click anywhere on the form surface area BUT away from any controls.
•	 Select Form Properties from the sub menu.

•	  The Form Properties dialog box appears. 
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Note: Decisions on storage locations if you are publishing to an Intranet or an Internet site will inevitably involve your 
administrator if you are working on behalf of a company or organisation you’re a part of.

Important: If you publish directly to your own web server or your Intranet, which connects seamlessly to the World 
Wide Web, you must consult your administrator about Firewall issues. 

Storing Form Results

The Results Storage Concept

When users access pages on your web they are browsing files in a folder. This folder is placed on the web server just like 
any other folder (or directory) on a server. This means you can have other files ready to contain data from form results. 
So, a web form is simply programmed to send results to another file in the same or a related folder on the server.

What Should Happen when a User Submits a Form

There is a multitude of ways the information can be stored; in different formats, within Open Database Connectivity 
(ODBC), ISAPI, NSAPI or CGI scripts and so on. Most of this is way above the scope of this manual. 

Using the Form Properties dialog box, the results of a submitted form can be stored as an HTML file or as a text file. 
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The former will allow the user to see the results as a web page, or part of a web page. The best example of this is a bulletin 
board, added to by a form, also discussion groups work in this way and the contributor can see his/her text tagged onto 
the bottom of a web page (HTML file). Of course, if you prefer, you can withhold the URL of the results page if you want 
the results in HTML format for your own use but don’t want the user to see the page.

The latter has great potential as, with text delimited information results, input from users can be transferred to other 
Office applications such as Excel or Word and used in mail merges or sorted and kept as databases.

Saving Results as an HTML File

Results data can be stored in any of four formats available in the form handler:

Choosing a Container for the Results

First, it’s a good idea to be clear about where you want your results to be stored in the web. The safest and most logical 
way is to create a new folder for input or form results.

To create a new folder for results
•	 Make sure you are in the Folders View.
•	 Click to select the folder at the top of the file structure tree pane. That is, the actual web folder itself. 
•	 From the menu bar, select File, New, Folder.

•	 A new folder appears at the bottom of the list of web folders. If there are folders in the list that contain sub 
folders, the new folder will appear above them.
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•	 Right-click the new folder and choose Rename from the sub menu.
•	 Rename the folder something friendly as a container for form results (how about ‘Results’).

Creating an HTML file to store the results (within the results folder) 

To create an HTML file
•	 Click the new (Results) folder in the folder structure tree pane.
•	 Click the New Page button on the toolbar.
•	 In the folder contents pane on the right, rename the new HTML file Guest.htm. Use the right mouse button 

again!
•	 This will be the file that stores the data input/results from the Guest Book form.

Directing Form Input to an HTML File

To save form input as an HTML file
•	 Open a web page that has a form on it in Page View. A good example to demonstrate this is a Guest Book 

such as the one below (used to record comments from users hitting the site). 

•	 In Normal view, right click in the form.
•	 Choose Form Properties from the sub menu.
•	 The Form Properties dialog box opens.
•	 In the Where to store Results’ section at the top of the dialog box, click the Send-to: radio button.
•	 Click the Browse button.
•	 The Current Web dialog box is opened and all the component folders and files are listed. 
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•	 Double-click the Results Folder icon.
•	 Click Guest.htm and select OK.
•	 Back at the Form Properties dialog box, click Options.
•	 At the Options for Saving Results of Form dialog box (shown below), click the File Results tab.
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•	 Click the File Format drop down menu button and select one of the HTML formats. 
•	 Select or de-select the field name and ‘Latest Results at End’ options. 
•	 Click OK.

Summary

Because you defined an HTML file as the target for the form results, you can visit the results file from your Internet 
browser and see the results in web page format. This will not be possible when saving results to a text file.

Preparing an HTML Page to Receive Form Results

As far as common editing is concerned, you can treat your Results HTML page the same as any other web page and add 
text, links and graphics and so on. Remember, you may want users to connect to this page.

To edit an HTML results page
•	 Open the results page in Page View.
•	 Make any changes or add items as necessary.
•	 Save the page.

Displaying a Form Submission Confirmation Page

 To set up a confirmation page
•	 First, you need to have designed a confirmation page in FrontPage Editor and saved it so that it’s part of 

your web.
•	 Right-click the form you wish to confirm.
•	 Select Form Properties from the sub menu.
•	 Click the Options button.
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•	 Click the Confirmation Page tab at the top of the dialog box (shown below).

•	 Type the URL path to the confirmation page in your web in the URL of confirmation page [Optional]: text 
field. Alternatively, click the Browse button and find it manually by clicking folders and files in the web.

•	 Click OK.

Saving Results as a Text File

Form results can be stored in any of four formats.

Formatted Text
This means readable text as you’d want to read it in your word 
processor.

Text database using comma as a 
separator

Commonly known as CSV files (Comma Separated Values). Used for 
feeding into a database or spreadsheet application that supports 
CSV.

Text database using tab as a 
separator

As with CSV this format places a tab between fields. This is the 
simplest way to feed data into Excel, and Word.

Text database using space 
As with CSV but using a space as a separator. This can cause 
confusion during import to other applications if there are any other 
spaces in the input range. Avoid this.
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Using the Formatted Text Option as a Target for Form Input

An ordinary text file will still be part of your web, ready to receive form results (or input) just like the HTML file in the 
previous section. However, it may not be possible for web browsers to view it on-line or be used to direct users to during 
their browsing of your web. If this is required there is a further format option: Formatted Text Within HTML. This option 
is in the same list as all the other format options, within Form Properties.

Text files are very easy to edit in word processors.

To save results in a text file
•	 In Folder View, create or find an appropriate folder for storing results. Note: If you followed instructions in 

the previous sections you can open the Results folder.
•	 Create a target file by clicking the New Page button on the toolbar. Use the file extension .doc.
•	 Open a form (preferably a Guest Book, even better - the one from earlier) in FrontPage Editor, Normal view.
•	 Right click and go to Form Properties.
•	 At the Form Properties dialog box, make sure the File Name field is empty.
•	 Click the Options button.
•	 Select the File Results tab.
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Note: If you want results to go to a text file and an HTML file, and you have already configured for results to be sent 
to HTML file, use the Optional Second File section.

•	 Click the File Format drop down menu button and select one of the Text formats.
•	 In the File Name text field, type the path to the .doc file you created or click the Browse button to find it 

manually.

Click OK. Input results will go to a Word document.

Opening the results file in Word

After testing the input form you will need to go to the Page View and refresh (update) the web files. 

To refresh the text results file
•	 Save any items open in Page View.
•	 Make sure you are in Folders view.
•	 Select View, Refresh from the menu bar.

As long as some form input has been made, you can now double click the Word icon and view the results in Word.

Using the Delimited Text Option as a Target for Form Input

If you want to use form results to feed in to a database application or spreadsheet or Word, follow the same route as in 
the previous section but choose one of the ‘separator’ text file formats.

18.4	 Sending Form Results to an E-Mail Address

Configuring the Form Properties to Send Results by E-mail

 To add an E-mail address as the recipient of results
•	 In Page View, with the form open, right click on the form.
•	 Select Form Properties from the sub menu.
•	 Select the E-mail Results tab in the dialog box shown below.
•	 Type an E-mail address in the address text box.
•	 Type a Subject Line so the recipient recognises the incoming E-mail as results of this particular form.
•	 Select the desired E-mail Format.
•	 Confirm by clicking OK.
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19	 Discussion Groups
By the end of this section you will be able to:

•	 Discussion Group Wizard
•	 Deleting material from the discussion

www.sylvania.com

We do not reinvent  
the wheel we reinvent 
light.
Fascinating lighting offers an infinite spectrum of 
possibilities: Innovative technologies and new  
markets provide both opportunities and challenges. 
An environment in which your expertise is in high 
demand. Enjoy the supportive working atmosphere 
within our global group and benefit from international 
career paths. Implement sustainable ideas in close 
cooperation with other specialists and contribute to 
influencing our future. Come and join us in reinventing 
light every day.
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19.1	 Discussion Groups

Create a discussion group to set up a forum for site visitors to communicate with each other. A discussion group is an 
interactive web site that lets site visitors discuss topics by reading articles that have been posted, replying to them, and 
posting new articles. Visitors can also use a search form to find articles of interest.

Create a discussion group on a web site

The easiest way to create a discussion group is by using the Discussion Web Wizard. The wizard asks for the features you 
want to use, then creates a web site and sets up the pages for you. After the web site is created, you can open the pages 
and customize them.

You can set the following properties for a discussion web site:

•	 The title of the discussion group 
•	 The discussion web directory in which to save articles 
•	 The format for the table of contents 
•	 Whether to use the colour and background scheme from another page in your web site 
•	 The pages to use as headers and footers in articles 
•	 Whether to include additional information in articles, such as the time and date 

You can also manage the articles that are posted in a discussion group. For example, you can modify an article that 
contains offensive language. 

Some of the content in this topic may not be applicable to some languages.

To create a discussion group
•	 On the File menu, point to New, and then click Page or Web. 
•	 In the New Page or Web task pane, under New from template, click Web Site Templates. 
•	 Click the Discussion Web Wizard. 
•	 If you want to add the discussion web site pages that the Discussion Web Wizard will create to the current 

web site instead of creating a new one, select Add to current web. 
•	 Click OK. 
•	 Follow the directions on your screen to create a discussion group. 

Notes: After the wizard has set up your web pages, you can open and modify them as necessary. 

You must publish your web site to a web server that has the FrontPage Server Extensions or Share Point Team Services 
from Microsoft installed. Ask your web administrator or Internet Service Provider whether this software is installed 
on your web server. Once the web site is published, click Preview in Browser icon to test the discussion group. 

Delete a web document discussion

Web document discussions are available only on webs hosted by web servers running Share Point Team Services from 
Microsoft.
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To Delete a web document discussion
•	 On Tools menu, point to Server, and then click Administration Home. 
•	 On the Site Administration page, under Web Discussions and Subscriptions, click Manage web discussions. 
•	 Select the check box next to the web document discussion that you would like to delete, and then click 

Delete. 

Note: If you don’t see the Manage web discussions option, you are probably in a sub web and need to go to the 
top-level web site of the server or virtual server. See your network administrator or ISP for more information.
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20	 Tasks
By the end of this section you will be able to:

•	 Creating personal Task
•	 Creating Task Requests
•	 Viewing task lists
•	 Editing tasks
•	 Marking Tasks as Complete
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20.1	 The FrontPage Tasks Manager

Working with Tasks

FrontPage tackles the problem of teams of people working on one web project by incorporating a Tasks list. In previous 
versions of FrontPage this was known as a To Do List. It is a similar feature to the Tasks list in Microsoft Outlook and 
Schedule Plus and other scheduling applications too.

If you are working in a team, members can assign and be assigned tasks connected with a web project and update them. 
At all times you can look to see what is being done and which tasks are completed. If you’re not fortunate enough to have 
people to help with your project, you can still use it as an area to record your progress and jot down things that need doing.

EADS unites a leading aircraft manufacturer, the world’s largest 
helicopter supplier, a global leader in space programmes and a 
worldwide leader in global security solutions and systems to form 
Europe’s largest defence and aerospace group. More than 
140,000 people work at Airbus, Astrium, Cassidian and Eurocopter, 
in 90 locations globally, to deliver some of the industry’s most 
exciting projects.

An EADS internship offers the chance to use your theoretical 
knowledge and apply it first-hand to real situations and assignments 
during your studies. Given a high level of responsibility, plenty of 

learning and development opportunities, and all the support you need, 
you will tackle interesting challenges on state-of-the-art products.

We welcome more than 5,000 interns every year across 
disciplines ranging from engineering, IT, procurement and 
finance, to strategy, customer support, marketing and sales. 
Positions are available in France, Germany, Spain and the UK.

To find out more and apply, visit www.jobs.eads.com. You can also 
find out more on our EADS Careers Facebook page.

Internship opportunities

CHALLENGING PERSPECTIVES
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The Tasks View

The Tasks view is accessed via the FrontPage Explorer.

To Create a New Task 
•	 In the Tasks View, choose File New and Task

•	 In the New Task dialog box, type a name for the task.
•	 In the Assigned to box, type or select the name of the person, workgroup, or other area you want to assign 

the task to. 
•	 In the Description box, type a description of the task. You can use this field to describe the work that needs 

to be completed or the work that was done on the task. 
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•	 In the Priority area, click a priority for the task. The default priority is Medium. 
•	 Click OK.

In any FrontPage view, you can manually add a task to the list in Task view by choosing File, New, Task

Viewing Task lists

To view your tasks
•	 On the View menu, click Tasks. 

Note: If completed tasks are not shown, right-click on the background in Tasks view, and then click Show History on 
the shortcut menu.

Editing Tasks

Double-clicking a task in the task list will launch the Task Details dialog box. From this point you can change the priority 
status and the description.

If you click the Do Task button, FrontPage will take you directly to the associated page that needs working on.

To change the name or description of a task
•	 In Tasks view, click the cell in the Task or Description column that you want to change, click the cell again, 

and then type the new name or description. 

Note: If a task has been marked as Completed, you can change the task’s description but not its name

To Mark a Task Complete
•	 In the Tasks View, right-click a task.
•	 From the pop-up menu, choose Mark Complete.

Completing a task turns its light green but you can, if you prefer, set the Tasks Window view to show only live tasks. On 
the View menu there is an option for Task History. Clicking this item toggles between Show and Hide Task History.

Note: If you want to actually delete a task when it’s done, right-click it and select delete instead of Mark Complete.
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21	 Administration
By the end of this section you will be able to:

•	 Checking Broken Links
•	 Recalculating links
•	 Internal Links
•	 Repeated Links
•	 Links to Images
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21.1	 External Hyperlinks

Testing your hyperlinks in FrontPage Editor is important. You need to make sure your hyperlinks go to the right page or 
location. When you follow a hyperlink, FrontPage scrolls to the bookmark or opens the target page if the page is in your 
current web. If the page is not in the current web, FrontPage Editor opens a copy of the page. 

To follow a hyperlink in Preview mode, simply right-click the hyperlink and choose Follow Hyperlink from the shortcut 
menu. Alternatively, you can hold down the [CTRL] button and double-click to follow links in this mode.

Verifying Hyperlinks

In FrontPage, you can determine which of your external hyperlinks are working and which are broken. This is a very 
useful feature since, if you’ve imported a web or if you just have a lot of links to WWW sites; it would take a long time 
using your web browser to check that they are all working. The FrontPage Hyperlink verifier will physically try to connect 
to the web sites and let you know if any of them are broken (i.e. they no longer exist or are down).

Although all the hyperlinks in the current web site are shown in the Reports view, Verify Hyperlinks is only available for 
external links.

To verify individuals hyperlinks are valid. 
•	 In Hyperlinks view, do the following: 
•	 Save all open pages. 
•	 On the View menu, choose Reports, Problems, and then Broken Hyperlinks. 
•	 The first time you run this report in a session, Microsoft FrontPage asks you to verify the hyperlinks in your 

web site. Choose Yes. 
•	 Right-click the file with the hyperlinks that you want to verify. 
•	 If a hyperlink’s destination is not in the current web site, the status of the hyperlink is Unknown. 
•	 On the Shortcut menu, click Verify Hyperlink. 

Note: This can be a lengthy process depending on the number of hyperlinks to verify and other factors such as your 
Internet connection speed. 

Repairing broken links

To repair broken hyperlinks
•	 On the View menu, Choose to Reports, Problems, and then Broken Hyperlinks. 
•	 All broken hyperlinks in the web site are listed. 
•	 If a hyperlink’s destination is not in the current web site, the status of the hyperlink is Unknown. 
•	 Double-click a hyperlink with broken status. 
•	 In the Edit Hyperlink dialog box, do one of the following: 
•	 To display the page so that you can edit it, click Edit Page. 
•	 If you know the correct URL of the page you want to link to, type it in the Replace hyperlink with box. Or, 

click Browse to browse to the page or file in a web site, file system, or on the WWW
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•	 To repair other occurrences of this hyperlink in all pages in the current web site, enter a valid hyperlink in 
the Replace hyperlink with box, click Change in all pages, and then click Replace. 

•	 To repair other occurrences of this hyperlink in selected pages, enter a valid hyperlink in the Replace 
hyperlink with box, and then click Change in selected pages. Select the pages, and then click Replace. 

Notes: If the new destination is valid, the hyperlink is no longer displayed as a broken hyperlink in the Broken 
Hyperlinks report. 

To Update all Hyperlinks
•	 Choose Tools, Recalculate Hyperlinks

•	 Click Yes to confirm 
•	 A list appears in the Explorer window showing the status of all 

Note: In a Web site based on Share Point Team Services from Microsoft, hyperlinks in document libraries and interactive 
lists are created and managed automatically. 
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